summaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-03-25 10:13:00 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-03-25 10:13:00 +0000
commit821bd49569acf55cc6489c762dc279f6da838dee (patch)
tree397901ecc16c129354cb037dac2ea1833855bdcb /target/linux/rdc/image/Makefile
parent35bb7be34d30252059144c1855f7397695b9362c (diff)
downloadmaster-31e0f0ae-821bd49569acf55cc6489c762dc279f6da838dee.tar.gz
master-31e0f0ae-821bd49569acf55cc6489c762dc279f6da838dee.tar.bz2
master-31e0f0ae-821bd49569acf55cc6489c762dc279f6da838dee.zip
use profiles again intead of subtargets.
We have now a single kernel which autodetects the type of device we are running on, so we can switch back to having profiles. Patch by Bernhard Loos. SVN-Revision: 20416
Diffstat (limited to 'target/linux/rdc/image/Makefile')
-rw-r--r--target/linux/rdc/image/Makefile16
1 files changed, 1 insertions, 15 deletions
diff --git a/target/linux/rdc/image/Makefile b/target/linux/rdc/image/Makefile
index 59d59b4a72..13e9da1fad 100644
--- a/target/linux/rdc/image/Makefile
+++ b/target/linux/rdc/image/Makefile
@@ -11,20 +11,6 @@ define Image/Prepare
$(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
endef
-define trxalign/jffs2-128k
-bs=128k
-endef
-define trxalign/jffs2-64k
-bs=64k
-endef
-define trxalign/squashfs
-bs=1024
-endef
-
-define Image/Prepare/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-endef
-
define Image/Build/ar525w
cp $(KDIR)/bzImage $(KDIR)/bzImage.tmp
$(SCRIPT_DIR)/pad_image $(1) $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) 32
@@ -53,7 +39,7 @@ endef
define Image/Build
$(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD).bzImage
- $(call Image/Build/$(SUBTARGET),$(1),$(SUBTARGET),$(patsubst jffs2-%k,%,$(1)))
+ $(call Image/Build/$(PROFILE),$(1),$(PROFILE),$(patsubst jffs2-%k,%,$(1)))
ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
$(call Image/Build/Initramfs)
endif