summaryrefslogtreecommitdiffstats
path: root/target/linux/rdc-2.6
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-05-25 23:41:07 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-05-25 23:41:07 +0000
commitb62d62a3c401de0140f029918730d8bf40cf395f (patch)
treebaf69ed3120f249c7b18b0dc72e1324e55539ca8 /target/linux/rdc-2.6
parent336885694424dcaa837fd54c515bb74f4d4aa409 (diff)
downloadmaster-31e0f0ae-b62d62a3c401de0140f029918730d8bf40cf395f.tar.gz
master-31e0f0ae-b62d62a3c401de0140f029918730d8bf40cf395f.tar.bz2
master-31e0f0ae-b62d62a3c401de0140f029918730d8bf40cf395f.zip
Update rdc to .21, mark it as broken
SVN-Revision: 7335
Diffstat (limited to 'target/linux/rdc-2.6')
-rw-r--r--target/linux/rdc-2.6/Makefile2
-rw-r--r--target/linux/rdc-2.6/config/default67
-rw-r--r--target/linux/rdc-2.6/patches/000-rdc_fixes.patch13
-rw-r--r--target/linux/rdc-2.6/patches/004-rdc3211_leds.patch14
4 files changed, 48 insertions, 48 deletions
diff --git a/target/linux/rdc-2.6/Makefile b/target/linux/rdc-2.6/Makefile
index 97dd29fdbd..bf0d0d41ad 100644
--- a/target/linux/rdc-2.6/Makefile
+++ b/target/linux/rdc-2.6/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=i386
BOARD:=rdc
BOARDNAME:=RDC x86
-FEATURES:=squashfs jffs2 pci
+FEATURES:=squashfs jffs2 pci broken
define Target/Description
Build firmware images for RDC3211 based routers
diff --git a/target/linux/rdc-2.6/config/default b/target/linux/rdc-2.6/config/default
index 77586338c4..66606a2073 100644
--- a/target/linux/rdc-2.6/config/default
+++ b/target/linux/rdc-2.6/config/default
@@ -1,24 +1,25 @@
# CONFIG_60XX_WDT is not set
# CONFIG_8139TOO is not set
-# CONFIG_ACPI is not set
# CONFIG_ACQUIRE_WDT is not set
# CONFIG_ADVANTECH_WDT is not set
# CONFIG_AGP is not set
-# CONFIG_AIRO_CS is not set
# CONFIG_ALIM1535_WDT is not set
# CONFIG_ALIM7101_WDT is not set
+# CONFIG_ARCH_HAS_ILOG2_U32 is not set
+# CONFIG_ARCH_HAS_ILOG2_U64 is not set
CONFIG_ARCH_MAY_HAVE_PC_FDC=y
CONFIG_ARCH_POPULATES_NODE_MAP=y
# CONFIG_B44 is not set
CONFIG_BASE_SMALL=0
CONFIG_BINFMT_AOUT=m
CONFIG_BINFMT_MISC=m
-# CONFIG_BLK_DEV_FD is not set
+CONFIG_BITREVERSE=y
# CONFIG_BLK_DEV_NBD is not set
# CONFIG_BONDING is not set
# CONFIG_BSD_PROCESS_ACCT is not set
CONFIG_BT_CMTP=m
CONFIG_CIFS_XATTR=y
+CONFIG_CLOCKSOURCE_WATCHDOG=y
# CONFIG_COMPAT_VDSO is not set
# CONFIG_CPU5_WDT is not set
# CONFIG_CPU_FREQ is not set
@@ -27,6 +28,7 @@ CONFIG_CRYPTO_ALGAPI=m
CONFIG_CRYPTO_BLKCIPHER=m
CONFIG_CRYPTO_CBC=m
CONFIG_CRYPTO_DES=m
+CONFIG_CRYPTO_DEV_GEODE=m
# CONFIG_CRYPTO_DEV_PADLOCK is not set
CONFIG_CRYPTO_MANAGER=m
CONFIG_CRYPTO_MD5=m
@@ -46,17 +48,19 @@ CONFIG_EARLY_PRINTK=y
# CONFIG_EDD is not set
# CONFIG_ENABLE_MUST_CHECK is not set
# CONFIG_EUROTECH_WDT is not set
-# CONFIG_FIRMWARE_EDID is not set
CONFIG_FS_POSIX_ACL=y
-# CONFIG_FTAPE is not set
CONFIG_FW_LOADER=m
+CONFIG_GENERIC_BUG=y
+CONFIG_GENERIC_CLOCKEVENTS=y
CONFIG_GENERIC_IOMAP=y
CONFIG_GENERIC_ISA_DMA=y
# CONFIG_GEN_RTC is not set
# CONFIG_HANGCHECK_TIMER is not set
+CONFIG_HAS_IOMEM=y
+CONFIG_HAS_IOPORT=y
# CONFIG_HIGHMEM4G is not set
# CONFIG_HIGHMEM64G is not set
-# CONFIG_HOSTAP_CS is not set
+# CONFIG_HIGH_RES_TIMERS is not set
# CONFIG_HPET_TIMER is not set
CONFIG_HUGETLBFS=y
CONFIG_HUGETLB_PAGE=y
@@ -68,6 +72,7 @@ CONFIG_HW_RANDOM=y
CONFIG_HZ=250
# CONFIG_HZ_100 is not set
CONFIG_HZ_250=y
+# CONFIG_HZ_300 is not set
# CONFIG_I2C is not set
# CONFIG_I6300ESB_WDT is not set
# CONFIG_I8K is not set
@@ -98,8 +103,8 @@ CONFIG_ISA_DMA_API=y
CONFIG_JFFS2_CMODE_SIZE=y
CONFIG_JFFS2_FS_DEBUG=0
CONFIG_JFFS2_RUBIN=y
-# CONFIG_KEXEC is not set
CONFIG_KTIME_SCALAR=y
+# CONFIG_KVM is not set
CONFIG_LEDS_RDC3211=m
CONFIG_LIBCRC32C=y
# CONFIG_M386 is not set
@@ -109,15 +114,16 @@ CONFIG_M486=y
# CONFIG_M586TSC is not set
# CONFIG_M686 is not set
# CONFIG_MACHZ_WDT is not set
+# CONFIG_MAC_EMUMOUSEBTN is not set
CONFIG_MATH_EMULATION=y
# CONFIG_MCA is not set
+# CONFIG_MCORE2 is not set
# CONFIG_MCRUSOE is not set
# CONFIG_MCYRIXIII is not set
# CONFIG_MEFFICEON is not set
# CONFIG_MGEODEGX1 is not set
# CONFIG_MGEODE_LX is not set
# CONFIG_MICROCODE is not set
-CONFIG_MINI_FO=y
# CONFIG_MK6 is not set
# CONFIG_MK7 is not set
# CONFIG_MK8 is not set
@@ -128,6 +134,7 @@ CONFIG_MODULE_FORCE_UNLOAD=y
# CONFIG_MPENTIUMM is not set
CONFIG_MTD=y
# CONFIG_MTD_ABSENT is not set
+CONFIG_MTD_BLKDEVS=y
CONFIG_MTD_BLOCK=y
# CONFIG_MTD_BLOCK2MTD is not set
CONFIG_MTD_CFI=y
@@ -179,7 +186,7 @@ CONFIG_MTD_RDC3210_SIZE=0x400000
# CONFIG_MTD_SLRAM is not set
# CONFIG_MTD_SPLIT_ROOTFS is not set
# CONFIG_MTD_TS5500 is not set
-CONFIG_MTRR=y
+# CONFIG_MTRR is not set
# CONFIG_MVIAC3_2 is not set
# CONFIG_MWAVE is not set
# CONFIG_MWINCHIP2 is not set
@@ -192,13 +199,28 @@ CONFIG_NETFILTER_XT_MATCH_QUOTA=m
CONFIG_NETFILTER_XT_MATCH_STATISTIC=m
CONFIG_NET_ACT_SIMP=m
# CONFIG_NET_PKTGEN is not set
+CONFIG_NET_SCH_FIFO=y
# CONFIG_NET_VENDOR_3COM is not set
# CONFIG_NFS_V4 is not set
+CONFIG_NF_CONNTRACK=y
+CONFIG_NF_CONNTRACK_MARK=y
+CONFIG_NF_CT_ACCT=y
+# CONFIG_NF_NAT_AMANDA is not set
+CONFIG_NF_NAT_FTP=m
+CONFIG_NF_NAT_H323=m
+CONFIG_NF_NAT_IRC=m
+CONFIG_NF_NAT_NEEDED=y
+# CONFIG_NF_NAT_PPTP is not set
+CONFIG_NF_NAT_SIP=m
+# CONFIG_NF_NAT_TFTP is not set
CONFIG_NOHIGHMEM=y
+CONFIG_NO_HZ=y
# CONFIG_NSC_GPIO is not set
CONFIG_NVRAM=y
CONFIG_PAGE_OFFSET=0xC0000000
+# CONFIG_PARAVIRT is not set
# CONFIG_PC8736x_GPIO is not set
+# CONFIG_PC87413_WDT is not set
# CONFIG_PCIEPORTBUS is not set
# CONFIG_PCIPCWATCHDOG is not set
CONFIG_PCI_BIOS=y
@@ -207,14 +229,11 @@ CONFIG_PCI_GOANY=y
# CONFIG_PCI_GOBIOS is not set
# CONFIG_PCI_GODIRECT is not set
# CONFIG_PCI_GOMMCONFIG is not set
-CONFIG_PCMCIA=m
-# CONFIG_PCMCIA_ATMEL is not set
-CONFIG_PCMCIA_IOCTL=y
-CONFIG_PCMCIA_LOAD_CIS=y
+CONFIG_PHYSICAL_ALIGN=0x100000
CONFIG_PHYSICAL_START=0x100000
-# CONFIG_PM is not set
+# CONFIG_PNPACPI is not set
CONFIG_R6040=y
-# CONFIG_REGPARM is not set
+# CONFIG_RELOCATABLE is not set
# CONFIG_RPCSEC_GSS_KRB5 is not set
# CONFIG_RTC is not set
CONFIG_RWSEM_XCHGADD_ALGORITHM=y
@@ -222,14 +241,9 @@ CONFIG_RWSEM_XCHGADD_ALGORITHM=y
# CONFIG_SBC_EPX_C3_WATCHDOG is not set
# CONFIG_SC1200_WDT is not set
# CONFIG_SC520_WDT is not set
-# CONFIG_SCSI_ADVANSYS is not set
-# CONFIG_SCSI_BUSLOGIC is not set
-# CONFIG_SCSI_EATA is not set
-# CONFIG_SCSI_GDTH is not set
# CONFIG_SCx200 is not set
# CONFIG_SECCOMP is not set
CONFIG_SEMAPHORE_SLEEPERS=y
-# CONFIG_SERIAL_8250_CS is not set
# CONFIG_SERIAL_8250_EXTENDED is not set
CONFIG_SERIAL_8250_NR_UARTS=4
# CONFIG_SMP is not set
@@ -239,18 +253,21 @@ CONFIG_SOFT_WATCHDOG=m
# CONFIG_SPARSEMEM_STATIC is not set
# CONFIG_SYSVIPC is not set
# CONFIG_TELCLOCK is not set
+CONFIG_TICK_ONESHOT=y
# CONFIG_TOSHIBA is not set
CONFIG_UID16=y
# CONFIG_UNUSED_SYMBOLS is not set
-# CONFIG_UNWIND_INFO is not set
# CONFIG_USBPCWATCHDOG is not set
CONFIG_USB_CXACRU=m
# CONFIG_USB_DEVICEFS is not set
+# CONFIG_USB_EHCI_BIG_ENDIAN_MMIO is not set
CONFIG_USB_EHCI_HCD=m
# CONFIG_USB_EHCI_ROOT_HUB_TT is not set
# CONFIG_USB_EHCI_SPLIT_ISO is not set
# CONFIG_USB_EHCI_TT_NEWSCHED is not set
CONFIG_USB_MON=y
+# CONFIG_USB_OHCI_BIG_ENDIAN_DESC is not set
+# CONFIG_USB_OHCI_BIG_ENDIAN_MMIO is not set
CONFIG_USB_OHCI_HCD=m
# CONFIG_USB_UHCI_HCD is not set
CONFIG_USB_XUSBATM=m
@@ -296,9 +313,5 @@ CONFIG_X86_RDC=y
# CONFIG_X86_VISWS is not set
# CONFIG_X86_VOYAGER is not set
CONFIG_X86_WP_WORKS_OK=y
-CONFIG_X86_XADD=y
-CONFIG_YENTA_ENE_TUNE=y
-CONFIG_YENTA_O2=y
-CONFIG_YENTA_RICOH=y
-CONFIG_YENTA_TI=y
-CONFIG_YENTA_TOSHIBA=y
+CONFIG_ZONE_DMA=y
+CONFIG_ZONE_DMA_FLAG=1
diff --git a/target/linux/rdc-2.6/patches/000-rdc_fixes.patch b/target/linux/rdc-2.6/patches/000-rdc_fixes.patch
index 140cde9a9b..148fc482b4 100644
--- a/target/linux/rdc-2.6/patches/000-rdc_fixes.patch
+++ b/target/linux/rdc-2.6/patches/000-rdc_fixes.patch
@@ -30,19 +30,6 @@ diff -urN linux-2.6.19/arch/i386/Makefile linux-2.6.19.new/arch/i386/Makefile
# default subarch .h files
mflags-y += -Iinclude/asm-i386/mach-default
-diff -urN linux-2.6.19/arch/i386/kernel/time.c linux-2.6.19.new/arch/i386/kernel/time.c
---- linux-2.6.19/arch/i386/kernel/time.c 2006-11-29 22:57:37.000000000 +0100
-+++ linux-2.6.19.new/arch/i386/kernel/time.c 2006-12-17 17:13:10.000000000 +0100
-@@ -361,7 +361,8 @@
- static void __init hpet_time_init(void)
- {
- struct timespec ts;
-- ts.tv_sec = get_cmos_time();
-+ /* RDC board does not have CMOS */
-+ ts.tv_sec = 0;
- ts.tv_nsec = (INITIAL_JIFFIES % HZ) * (NSEC_PER_SEC / HZ);
-
- do_settimeofday(&ts);
diff -urN linux-2.6.19/arch/i386/mach-rdc/Makefile linux-2.6.19.new/arch/i386/mach-rdc/Makefile
--- linux-2.6.19/arch/i386/mach-rdc/Makefile 1970-01-01 01:00:00.000000000 +0100
+++ linux-2.6.19.new/arch/i386/mach-rdc/Makefile 2006-12-17 17:13:33.000000000 +0100
diff --git a/target/linux/rdc-2.6/patches/004-rdc3211_leds.patch b/target/linux/rdc-2.6/patches/004-rdc3211_leds.patch
index 3de3c8da55..2e704aa600 100644
--- a/target/linux/rdc-2.6/patches/004-rdc3211_leds.patch
+++ b/target/linux/rdc-2.6/patches/004-rdc3211_leds.patch
@@ -14,13 +14,13 @@ diff -urN linux-2.6.19.2/drivers/leds/Kconfig linux-2.6.19.2.new/drivers/leds/Kc
comment "LED Triggers"
config LEDS_TRIGGERS
-diff -urN linux-2.6.19.2/drivers/leds/Makefile linux-2.6.19.2.new/drivers/leds/Makefile
---- linux-2.6.19.2/drivers/leds/Makefile 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2.new/drivers/leds/Makefile 2007-04-16 22:09:55.000000000 +0200
-@@ -13,6 +13,7 @@
- obj-$(CONFIG_LEDS_S3C24XX) += leds-s3c24xx.o
- obj-$(CONFIG_LEDS_AMS_DELTA) += leds-ams-delta.o
- obj-$(CONFIG_LEDS_NET48XX) += leds-net48xx.o
+diff -urN linux-2.6.21.1/drivers/leds/Makefile linux-2.6.21.1.new/drivers/leds/Makefile
+--- linux-2.6.21.1/drivers/leds/Makefile 2007-04-27 23:49:26.000000000 +0200
++++ linux-2.6.21.1.new/drivers/leds/Makefile 2007-05-25 12:19:13.000000000 +0200
+@@ -16,6 +16,7 @@
+ obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
+ obj-$(CONFIG_LEDS_H1940) += leds-h1940.o
+ obj-$(CONFIG_LEDS_COBALT) += leds-cobalt.o
+obj-$(CONFIG_LEDS_RDC3211) += leds-rdc3211.o
# LED Triggers