summaryrefslogtreecommitdiffstats
path: root/target/linux/rb532
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
commit6a4f2922f6303a006d66b4bbb79541823b1c12b4 (patch)
treed3d9644c2a4a2e9b758bab9b84973e078143ed2c /target/linux/rb532
parenteab95ea46736f8359c5a19a612f0e39160cab80c (diff)
downloadmaster-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.gz
master-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.bz2
master-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.zip
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 37049
Diffstat (limited to 'target/linux/rb532')
-rw-r--r--target/linux/rb532/image/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/target/linux/rb532/image/Makefile b/target/linux/rb532/image/Makefile
index da4baaa48a..d1236410db 100644
--- a/target/linux/rb532/image/Makefile
+++ b/target/linux/rb532/image/Makefile
@@ -29,12 +29,12 @@ define Image/Prepare
endef
VMLINUX:=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux-kernel
-ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
- VMLINUX:=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs
-endif
define Image/BuildKernel
$(CP) $(KDIR)/loader.elf $(VMLINUX)
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(CP) $(KDIR)/loader.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs
+endif
endef
define Image/cmdline/jffs2-64k
@@ -65,9 +65,10 @@ endef
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
define Image/Prepare
- $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux '$(strip $(call Image/cmdline/yaffs2)) '
- cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
+ $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-initramfs '$(strip $(call Image/cmdline/yaffs2)) '
+ cat $(KDIR)/vmlinux-initramfs | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux-initramfs.lzma
$(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
+ $(CP) $(KDIR)/loader.elf $(KDIR)/loader-initramfs.elf
endef
endif