summaryrefslogtreecommitdiffstats
path: root/target/linux/rb532
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-24 13:17:39 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-24 13:17:39 +0000
commit13ec78c18f4cf10b44a551110468f613fdaff3f5 (patch)
tree6874eaef12c654805c1612def189fded13128d04 /target/linux/rb532
parent91e1fa6d70a2a6d8fc95b966efb960d424380e8a (diff)
downloadmaster-31e0f0ae-13ec78c18f4cf10b44a551110468f613fdaff3f5.tar.gz
master-31e0f0ae-13ec78c18f4cf10b44a551110468f613fdaff3f5.tar.bz2
master-31e0f0ae-13ec78c18f4cf10b44a551110468f613fdaff3f5.zip
rb532: image: fix broken ifneq statement
Fixes the following build error: /devel/openwrt/staging_dir/host/bin/patch-cmdline \ /devel/openwrt/build_dir/target-mipsel_uClibc-0.9.33.2/linux-rb532/vmlinux-initramfs \ 'root=/dev/mtdblock1 rootfstype=yaffs2 ' Could not open kernel imagemake[5]: *** [install] Error 255 Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38157
Diffstat (limited to 'target/linux/rb532')
-rw-r--r--target/linux/rb532/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/rb532/image/Makefile b/target/linux/rb532/image/Makefile
index fea6c94198..5f421bbe28 100644
--- a/target/linux/rb532/image/Makefile
+++ b/target/linux/rb532/image/Makefile
@@ -63,7 +63,7 @@ define Image/Build
./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).bin 4 $(BIN_DIR)/$(IMG_PREFIX)-$(1).kernel $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
endef
-ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
define Image/Prepare
$(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-initramfs '$(strip $(call Image/cmdline/yaffs2)) '
cat $(KDIR)/vmlinux-initramfs | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux-initramfs.lzma