summaryrefslogtreecommitdiffstats
path: root/target/linux/rb532
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2011-05-04 08:47:00 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2011-05-04 08:47:00 +0000
commit67339c1329562e1afcac13fceb0c6c4f8d8b299f (patch)
treea9717c7432cff11e493e5f74a3c5bff1823cae6b /target/linux/rb532
parent9736cfef6646a2748de35d680f32cbc3c903ad59 (diff)
downloadmaster-31e0f0ae-67339c1329562e1afcac13fceb0c6c4f8d8b299f.tar.gz
master-31e0f0ae-67339c1329562e1afcac13fceb0c6c4f8d8b299f.tar.bz2
master-31e0f0ae-67339c1329562e1afcac13fceb0c6c4f8d8b299f.zip
linux/rb532: use kernel and initramfs tags on image generation
SVN-Revision: 26817
Diffstat (limited to 'target/linux/rb532')
-rw-r--r--target/linux/rb532/image/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/rb532/image/Makefile b/target/linux/rb532/image/Makefile
index b7849cbda3..da4baaa48a 100644
--- a/target/linux/rb532/image/Makefile
+++ b/target/linux/rb532/image/Makefile
@@ -28,8 +28,13 @@ define Image/Prepare
$(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
endef
+VMLINUX:=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux-kernel
+ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+ VMLINUX:=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs
+endif
+
define Image/BuildKernel
- $(CP) $(KDIR)/loader.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
+ $(CP) $(KDIR)/loader.elf $(VMLINUX)
endef
define Image/cmdline/jffs2-64k
@@ -64,9 +69,6 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
$(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
endef
- define Image/BuildKernel
- $(CP) $(KDIR)/loader.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
- endef
endif
$(eval $(call BuildImage))