summaryrefslogtreecommitdiffstats
path: root/target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-07-15 17:17:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-07-15 17:17:04 +0000
commit714a721010caa3941e7e178944c9e843c2108b59 (patch)
tree771fc56ebd8a3ccf3ee0b7903e8f33ce94946fba /target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch
parent651a729a9c8cca75297471afdfcdd88da8d05b23 (diff)
downloadmaster-31e0f0ae-714a721010caa3941e7e178944c9e843c2108b59.tar.gz
master-31e0f0ae-714a721010caa3941e7e178944c9e843c2108b59.tar.bz2
master-31e0f0ae-714a721010caa3941e7e178944c9e843c2108b59.zip
Move files and patches to files-2.6.23 and patches-2.6.23
SVN-Revision: 11843
Diffstat (limited to 'target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch')
-rw-r--r--target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch b/target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch
new file mode 100644
index 0000000000..acfba6c00a
--- /dev/null
+++ b/target/linux/rb532/patches-2.6.23/110-korina_ethernet.patch
@@ -0,0 +1,31 @@
+Index: linux-2.6.23.17/drivers/net/Kconfig
+===================================================================
+--- linux-2.6.23.17.orig/drivers/net/Kconfig
++++ linux-2.6.23.17/drivers/net/Kconfig
+@@ -348,6 +348,13 @@ config AX88796
+ AX88796 driver, using platform bus to provide
+ chip detection and resources
+
++config KORINA
++ tristate "Korina Local Ethernet support"
++ depends on NET_ETHERNET && ( IDT_EB434 || MIKROTIK_RB500)
++ help
++ IDT RC32434 has one local ethernet port. Say Y here to enable it.
++ To compile this driver as a module, choose M here.
++
+ config MACE
+ tristate "MACE (Power Mac ethernet) support"
+ depends on PPC_PMAC && PPC32
+Index: linux-2.6.23.17/drivers/net/Makefile
+===================================================================
+--- linux-2.6.23.17.orig/drivers/net/Makefile
++++ linux-2.6.23.17/drivers/net/Makefile
+@@ -25,6 +25,8 @@ ucc_geth_driver-objs := ucc_geth.o ucc_g
+ #
+ obj-$(CONFIG_PLIP) += plip.o
+
++obj-$(CONFIG_KORINA) += korina.o
++
+ obj-$(CONFIG_ROADRUNNER) += rrunner.o
+
+ obj-$(CONFIG_HAPPYMEAL) += sunhme.o