summaryrefslogtreecommitdiffstats
path: root/target/linux/rb532/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-11 00:45:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-11 00:45:28 +0000
commite8a39ef67733050892f3b216a231f2416d28e872 (patch)
tree28d86a3be88f0692b1116c8c44a34d7d6543a9a3 /target/linux/rb532/image
parent5f1ef3ab83f0270bd78262e62b56dd6405eb8534 (diff)
downloadmaster-31e0f0ae-e8a39ef67733050892f3b216a231f2416d28e872.tar.gz
master-31e0f0ae-e8a39ef67733050892f3b216a231f2416d28e872.tar.bz2
master-31e0f0ae-e8a39ef67733050892f3b216a231f2416d28e872.zip
rb532: preserve commandline-patched kernel images for faster kernel testing via netboot
SVN-Revision: 15766
Diffstat (limited to 'target/linux/rb532/image')
-rw-r--r--target/linux/rb532/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/rb532/image/Makefile b/target/linux/rb532/image/Makefile
index a29ddf8280..9d0857dec8 100644
--- a/target/linux/rb532/image/Makefile
+++ b/target/linux/rb532/image/Makefile
@@ -54,8 +54,9 @@ root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
endef
define Image/Build
- $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
- ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
+ $(CP) $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(1).kernel
+ $(STAGING_DIR_HOST)/bin/patch-cmdline $(BIN_DIR)/openwrt-$(BOARD)-$(1).kernel '$(strip $(call Image/cmdline/$(1))) '
+ ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).bin 4 $(BIN_DIR)/openwrt-$(BOARD)-$(1).kernel $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
endef
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)