summaryrefslogtreecommitdiffstats
path: root/target/linux/rb532/image
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commite2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f (patch)
treef8563604e7685c30b0a2a675ca80379a34114565 /target/linux/rb532/image
parent040c06438896144dfe148910f922a0d9bb0058b0 (diff)
downloadmaster-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.gz
master-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.bz2
master-31e0f0ae-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
SVN-Revision: 20834
Diffstat (limited to 'target/linux/rb532/image')
-rw-r--r--target/linux/rb532/image/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/target/linux/rb532/image/Makefile b/target/linux/rb532/image/Makefile
index 9f1ec23057..17ff67cc36 100644
--- a/target/linux/rb532/image/Makefile
+++ b/target/linux/rb532/image/Makefile
@@ -1,12 +1,11 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-include $(INCLUDE_DIR)/kernel.mk
LOADADDR = 0x81000000 # RAM start + 16M
KERNEL_ENTRY = 0x80101000
@@ -30,7 +29,7 @@ define Image/Prepare
endef
define Image/BuildKernel
- $(CP) $(KDIR)/loader.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux
+ $(CP) $(KDIR)/loader.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
endef
define Image/cmdline/jffs2-64k
@@ -54,9 +53,9 @@ root=/dev/mtdblock1 rootfstype=yaffs2
endef
define Image/Build
- $(CP) $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(1).kernel
- $(STAGING_DIR_HOST)/bin/patch-cmdline $(BIN_DIR)/openwrt-$(BOARD)-$(1).kernel '$(strip $(call Image/cmdline/$(1))) '
- ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).bin 4 $(BIN_DIR)/openwrt-$(BOARD)-$(1).kernel $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
+ $(CP) $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-$(1).kernel
+ $(STAGING_DIR_HOST)/bin/patch-cmdline $(BIN_DIR)/$(IMG_PREFIX)-$(1).kernel '$(strip $(call Image/cmdline/$(1))) '
+ ./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-$(1).bin 4 $(BIN_DIR)/$(IMG_PREFIX)-$(1).kernel $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
endef
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
@@ -66,7 +65,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
$(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
endef
define Image/BuildKernel
- $(CP) $(KDIR)/loader.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux
+ $(CP) $(KDIR)/loader.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
endef
endif