summaryrefslogtreecommitdiffstats
path: root/target/linux/rb532-2.6/base-files.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-06 18:31:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-06 18:31:28 +0000
commit63994b8f50ca94e0885ed9a00c29eaeeda7c36fe (patch)
treebf0a2663a31ed16a9ae7550e05818f77f6d20177 /target/linux/rb532-2.6/base-files.mk
parente1dc2f086daaa231d50a3852afad8642353add0f (diff)
downloadmaster-31e0f0ae-63994b8f50ca94e0885ed9a00c29eaeeda7c36fe.tar.gz
master-31e0f0ae-63994b8f50ca94e0885ed9a00c29eaeeda7c36fe.tar.bz2
master-31e0f0ae-63994b8f50ca94e0885ed9a00c29eaeeda7c36fe.zip
replace the ugly rb532 cmdline hack with a cleaner one that does not depend on magic offsets
SVN-Revision: 5699
Diffstat (limited to 'target/linux/rb532-2.6/base-files.mk')
-rw-r--r--target/linux/rb532-2.6/base-files.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/rb532-2.6/base-files.mk b/target/linux/rb532-2.6/base-files.mk
new file mode 100644
index 0000000000..afd1220c56
--- /dev/null
+++ b/target/linux/rb532-2.6/base-files.mk
@@ -0,0 +1,11 @@
+define Build/Compile
+ $(call Build/Compile/Default)
+ $(TARGET_CC) -o $(PKG_BUILD_DIR)/patch-cmdline $(PLATFORM_DIR)/src/patch-cmdline.c
+endef
+
+define Package/base-files/install-target
+ mkdir -p $(1)/sbin
+ $(CP) $(PKG_BUILD_DIR)/patch-cmdline $(1)/sbin
+endef
+
+