summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-08-20 01:18:51 +0200
committerMathias Kresin <dev@kresin.me>2016-08-20 11:47:25 +0200
commitc9e6b173f7477f3ff29d4c7c589f7ce5b360eeba (patch)
tree74d4c06d923cda5ead5ef7b7527cf8fa1c6cb4f0 /target/linux/ramips
parentc892f37b30925bb298bd5f79aa7c9ba2f1809e32 (diff)
downloadmaster-31e0f0ae-c9e6b173f7477f3ff29d4c7c589f7ce5b360eeba.tar.gz
master-31e0f0ae-c9e6b173f7477f3ff29d4c7c589f7ce5b360eeba.tar.bz2
master-31e0f0ae-c9e6b173f7477f3ff29d4c7c589f7ce5b360eeba.zip
ramips: fix build of TRENDnet TEW-69xGR images
The image generation for TEW-691GR and TEW-692GR was broken since 79d02229 due to the move of the UMedia recipe to another Makefile. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/rt3883.mk36
1 files changed, 20 insertions, 16 deletions
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index 74c12404df..edfd43cd6b 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -2,6 +2,26 @@
# RT3662/RT3883 Profiles
#
+define Device/TEW691GR
+ DTS := TEW-691GR
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | umedia-header 0x026910
+ DEVICE_TITLE := TRENDnet TEW-691GR
+ DEVICE_PACKAGES := swconfig
+endef
+TARGET_DEVICES += TEW691GR
+
+
+define Device/TEW692GR
+ DTS := TEW-692GR
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | umedia-header 0x026920
+ DEVICE_TITLE := TRENDnet TEW-692GR
+ DEVICE_PACKAGES := swconfig
+endef
+TARGET_DEVICES += TEW692GR
+
+
# $(1) = squashfs/initramfs
# $(2) = lowercase board name
# $(3) = dts file
@@ -41,8 +61,6 @@ Image/Build/Profile/DIR645=$(call BuildFirmware/Seama/$(1),$(1),dir-645,DIR-645,
hpm_mtd_size=16449536
Image/Build/Profile/HPM=$(call BuildFirmware/CustomFlash/$(1),$(1),hpm,HPM,$(hpm_mtd_size))
Image/Build/Profile/RTN56U=$(call BuildFirmware/RTN56U/$(1),$(1),rt-n56u,RT-N56U)
-Image/Build/Profile/TEW691GR=$(call BuildFirmware/UMedia/$(1),$(1),tew-691gr,TEW-691GR,0x026910)
-Image/Build/Profile/TEW692GR=$(call BuildFirmware/UMedia/$(1),$(1),tew-692gr,TEW-692GR,0x026920)
kernel_size_BR6475ND:=2097152
rootfs_size_BR6475ND:=5832704
Image/Build/Profile/BR6475ND=$(call BuildFirmware/EdimaxCombined/$(1),$(1),br-6475nd,BR-6475ND,$(kernel_size_BR6475ND),$(rootfs_size_BR6475ND),CSYS,RN54,0x70000,0x01100000)
@@ -76,20 +94,6 @@ endef
LEGACY_DEVICES += RTN56U
-define LegacyDevice/TEW691GR
- DEVICE_TITLE := TRENDnet TEW-691GR
- DEVICE_PACKAGES := swconfig
-endef
-LEGACY_DEVICES += TEW691GR
-
-
-define LegacyDevice/TEW692GR
- DEVICE_TITLE := TEW692GR
- DEVICE_PACKAGES := swconfig
-endef
-LEGACY_DEVICES += TEW692GR
-
-
define LegacyDevice/BR6475ND
DEVICE_TITLE := Edimax BR-6475nD
DEVICE_PACKAGES := swconfig