summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-03-07 09:54:59 +0000
committerJohn Crispin <john@openwrt.org>2014-03-07 09:54:59 +0000
commit96fa58bafd6b311a9a3686b704bf8074905c4bea (patch)
treea3d1d3c06fc423ed2acff476d6feb8a1903b3604 /target/linux/ramips
parentd3f39e89a356185f94c184dbaa410d620f6162b5 (diff)
downloadmaster-31e0f0ae-96fa58bafd6b311a9a3686b704bf8074905c4bea.tar.gz
master-31e0f0ae-96fa58bafd6b311a9a3686b704bf8074905c4bea.tar.bz2
master-31e0f0ae-96fa58bafd6b311a9a3686b704bf8074905c4bea.zip
ralink: add support for wrtnode
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 39786
Diffstat (limited to 'target/linux/ramips')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/02_network1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh2
-rw-r--r--target/linux/ramips/dts/WRTNODE.dts76
-rw-r--r--target/linux/ramips/image/Makefile2
5 files changed, 84 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/02_network b/target/linux/ramips/base-files/etc/uci-defaults/02_network
index 703471838d..1cbf7bf022 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/02_network
+++ b/target/linux/ramips/base-files/etc/uci-defaults/02_network
@@ -96,6 +96,7 @@ ramips_setup_interfaces()
f5d8235-v2 | \
hg255d | \
rt-n14u | \
+ wrtnode | \
ur-326n4g)
ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
ucidef_add_switch "switch0" "1" "1"
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 5a686e6719..a3a26cb23e 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -280,6 +280,9 @@ ramips_board_detect() {
*"V22SG")
name="v22sg"
;;
+ *"WRTNODE")
+ name="wrtnode"
+ ;;
*"Sercomm NA930")
name="na930"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 8bc2abd156..8ff6063f19 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -84,6 +84,8 @@ platform_check_image() {
ur-326n4g |\
ur-336un |\
wr512-3gn |\
+ wmr300 |\
+ wrtnode |\
x5 |\
x8)
[ "$magic" != "27051956" ] && {
diff --git a/target/linux/ramips/dts/WRTNODE.dts b/target/linux/ramips/dts/WRTNODE.dts
new file mode 100644
index 0000000000..33d7c9136e
--- /dev/null
+++ b/target/linux/ramips/dts/WRTNODE.dts
@@ -0,0 +1,76 @@
+/dts-v1/;
+
+/include/ "mt7620n.dtsi"
+
+/ {
+ compatible = "wrtnode", "ralink,mt7620n-soc";
+ model = "WRTNode";
+
+ palmbus@10000000 {
+ gpio2: gpio@660 {
+ status = "okay";
+ };
+
+ gpio3: gpio@688 {
+ status = "okay";
+ };
+
+ spi@b00 {
+ status = "okay";
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "mx25l12805d";
+ reg = <0 0>;
+ linux,modalias = "m25p80", "w25q128";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0xfb0000>;
+ };
+ };
+ };
+ };
+
+ ehci@101c0000 {
+ status = "okay";
+ };
+
+ ohci@101c1000 {
+ status = "okay";
+ };
+
+ ethernet@10100000 {
+ mtd-mac-address = <&factory 0x4>;
+ ralink,port-map = "wllll";
+ };
+
+ pinctrl {
+ state_default: pinctrl0 {
+ default {
+ ralink,group = "ephy", "wled", "pa", "i2c", "wdt", "uartf";
+ ralink,function = "gpio";
+ };
+ };
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index ae95b68655..c6a42ad8e7 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -690,11 +690,13 @@ endif
Image/Build/Profile/WMR300=$(call BuildFirmware/Default8M/$(1),$(1),wmr-300,WMR300)
Image/Build/Profile/RT-N14U=$(call BuildFirmware/Default8M/$(1),$(1),rt-n14u,RT-N14U)
+Image/Build/Profile/WRTNODE=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode,WRTNODE)
ifeq ($(SUBTARGET),mt7620n)
define Image/Build/Profile/Default
$(call Image/Build/Profile/WMR300,$(1))
$(call Image/Build/Profile/RT-N14U,$(1))
+ $(call Image/Build/Profile/WRTNODE,$(1))
endef
endif