summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt3883/profiles
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-02 12:42:52 +0000
committerJohn Crispin <john@openwrt.org>2014-06-02 12:42:52 +0000
commit813a7c3827afe71f49f2985c607585900a7db4fb (patch)
treebf7b310aad63e81c8676b0615f3a3adf01447a9b /target/linux/ramips/rt3883/profiles
parentefd09832febde11e9d4bc6fca6e471f94933867f (diff)
downloadmaster-31e0f0ae-813a7c3827afe71f49f2985c607585900a7db4fb.tar.gz
master-31e0f0ae-813a7c3827afe71f49f2985c607585900a7db4fb.tar.bz2
master-31e0f0ae-813a7c3827afe71f49f2985c607585900a7db4fb.zip
ralink: Add support for samsung cy-swr1100 wireless router
It is base on rt3662 soc with dual band 802.11n wireless router. Use rtl8367R switch chip. This patch adds a profile for this board. It use seama image header. so i also enable it on kernel config. Signed-off-by: michael lee <igvtee@gmail.com> SVN-Revision: 40908
Diffstat (limited to 'target/linux/ramips/rt3883/profiles')
-rw-r--r--target/linux/ramips/rt3883/profiles/samsung.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/rt3883/profiles/samsung.mk b/target/linux/ramips/rt3883/profiles/samsung.mk
new file mode 100644
index 0000000000..18f60d4a3c
--- /dev/null
+++ b/target/linux/ramips/rt3883/profiles/samsung.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/CYSWR1100
+ NAME:=Samsung CY-SWR1100
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+endef
+
+define Profile/CYSWR1100/Description
+ Package set compatible with the Samsung CY-SWR1100 board.
+endef
+$(eval $(call Profile,CYSWR1100))