summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-06 04:52:07 +0000
committerJohn Crispin <john@openwrt.org>2014-10-06 04:52:07 +0000
commitb04bb3eea71338214ed83671f026e3e2625d23e8 (patch)
tree4c4369fcfa51a9951795dd86ba1b74349be6823a /target/linux/ramips/rt305x
parent7ab5357280ba8d15ebb9a7b1121a754b1c473fd1 (diff)
downloadmaster-31e0f0ae-b04bb3eea71338214ed83671f026e3e2625d23e8.tar.gz
master-31e0f0ae-b04bb3eea71338214ed83671f026e3e2625d23e8.tar.bz2
master-31e0f0ae-b04bb3eea71338214ed83671f026e3e2625d23e8.zip
ramips: Support for RAMIPS based Tripmate HT-TM02 board
Provides support for the Tripmate HT-TM02 personal router including LEDs and reset button. “Mode” switch is not supported. New profile includes full set of packages required to enable LEDs, USB, and LUCI. Patches were applied against trunk snapshot r42649. Functionality has been tested in AP, basic wifi client, wifi router, and routed client modes - all good. Signed-off-by: Ron Curry <wingspinner@gmail.com> SVN-Revision: 42785
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/hootoo.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/hootoo.mk b/target/linux/ramips/rt305x/profiles/hootoo.mk
new file mode 100644
index 0000000000..976226d5bd
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/hootoo.mk
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+
+define Profile/HT-TM02
+ NAME:=HOOTOO HT-TM02
+ PACKAGES:=\
+ wpad-mini \
+ kmod-ledtrig-netdev kmod-ledtrig-timer kmod-leds-gpio kmod-ledtrig-default-on \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-net usbutils \
+ kmod-scsi-core kmod-scsi-generic kmod-fs-ext4 \
+ kmod-usb-storage kmod-usb-storage-extras block-mount \
+ kmod-usb-serial kmod-usb-serial-ftdi kmod-gpio-button-hotplug \
+ kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-utf8 luci luci-mod-admin-full \
+ kmod-app-samba luci-theme-openwrt luci-proto-relay relayd nano \
+ fstools
+endef
+
+define Profile/HT-TM02/Description
+ Package set for HOOTOO HT-TM02 board
+endef
+
+$(eval $(call Profile,HT-TM02))
+