summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-04 08:33:12 +0000
committerJohn Crispin <john@openwrt.org>2016-03-04 08:33:12 +0000
commit9d828931f12c70d503194e0e98e9ad5a69d47554 (patch)
tree6a43e3ae5f9deeee9cef4f732b575e65cca81dd0 /target/linux/ramips/rt305x
parent43dd2b996522b0588e5f91a4c746a01d4130655c (diff)
downloadmaster-31e0f0ae-9d828931f12c70d503194e0e98e9ad5a69d47554.tar.gz
master-31e0f0ae-9d828931f12c70d503194e0e98e9ad5a69d47554.tar.bz2
master-31e0f0ae-9d828931f12c70d503194e0e98e9ad5a69d47554.zip
ramips: Add profiles for JCG routers
This patch adds profiles and support for building factory and sysupgrade images for JHR-N805R, JHR-N825R and JHR-N926R. Signed-off-by: Reinhard Max <reinhard@m4x.de> Reviewed-by: Torsten Duwe <duwe@lst.de> SVN-Revision: 48906
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/jcg.mk43
1 files changed, 43 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/jcg.mk b/target/linux/ramips/rt305x/profiles/jcg.mk
new file mode 100644
index 0000000000..5029ca925f
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/jcg.mk
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/JCG
+ NAME=JCG Routers
+endef
+
+define Profile/JCG/Description
+ Builds images for JHR-N805R, JHR-N825R, and JHR-N926R.
+endef
+$(eval $(call Profile,JCG))
+
+define Profile/JHR-N805R
+ NAME:=JCG JHR-N805R
+endef
+
+define Profile/JHR-N805R/Description
+ Package set for JCG JHR-N805R
+endef
+$(eval $(call Profile,JHR-N805R))
+
+define Profile/JHR-N825R
+ NAME:=JCG JHR-N825R
+endef
+
+define Profile/JHR-N825R/Description
+ Package set for JCG JHR-N825R
+endef
+$(eval $(call Profile,JHR-N825R))
+
+define Profile/JHR-N926R
+ NAME:=JCG JHR-N926R
+endef
+
+define Profile/JHR-N926R/Description
+ Package set for JCG JHR-N926R
+endef
+$(eval $(call Profile,JHR-N926R))
+