summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-22 09:35:22 +0000
committerJohn Crispin <john@openwrt.org>2015-01-22 09:35:22 +0000
commit36d19e46dfbf0a6baa4f741e8182fbd72dd6575e (patch)
treec13d6f4cda1dd5c11a8fddcb6a7e7d1b868be74b /target/linux/ramips/rt305x
parentdeb66a555e8856d253a5feb6620ae4d50f404e69 (diff)
downloadmaster-31e0f0ae-36d19e46dfbf0a6baa4f741e8182fbd72dd6575e.tar.gz
master-31e0f0ae-36d19e46dfbf0a6baa4f741e8182fbd72dd6575e.tar.bz2
master-31e0f0ae-36d19e46dfbf0a6baa4f741e8182fbd72dd6575e.zip
ramips: add support for Tenda 3G150B
Add suport for Tenda 3G150B: - cpu: Ralink RT5350F - flash: 4MB - ram: 32MB - 1x USB 2.0 - 1x RJ45 - one reset button - battery powered (BP-4L, 3.7V 1450mAh) Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com> SVN-Revision: 44073
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/tenda.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/tenda.mk b/target/linux/ramips/rt305x/profiles/tenda.mk
index d9d94cfbb9..36ba822b44 100644
--- a/target/linux/ramips/rt305x/profiles/tenda.mk
+++ b/target/linux/ramips/rt305x/profiles/tenda.mk
@@ -5,6 +5,19 @@
# See /LICENSE for more information.
#
+define Profile/3G150B
+ NAME:=Tenda 3G150B
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-dwc2 \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/3G150B/Description
+ Package set for Tenda 3G150B board
+endef
+
+$(eval $(call Profile,3G150B))
+
define Profile/3G300M
NAME:=Tenda 3G300M
PACKAGES:=\