summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-08 20:26:20 +0000
committerJohn Crispin <john@openwrt.org>2015-01-08 20:26:20 +0000
commit2120e48e758e68aa129f39e59d5dc72bfc648982 (patch)
tree570f17a352b7d6f5419a18d2d86611b531ed5c4c /target/linux/ramips/rt305x
parent5ea31bbc582c745abea2a54ccfd341fade1207cd (diff)
downloadmaster-31e0f0ae-2120e48e758e68aa129f39e59d5dc72bfc648982.tar.gz
master-31e0f0ae-2120e48e758e68aa129f39e59d5dc72bfc648982.tar.bz2
master-31e0f0ae-2120e48e758e68aa129f39e59d5dc72bfc648982.zip
ramips: Fix HooToo HT-TM02 support.
- Fix LED definitions. - Add mode-switch slider definition (at GPIO 14). - Remove unneeded VLAN now that the ethernet driver is fixed and TCP packets get passed correctly now. (This router only has one port.) - Fix LAN port MAC address, which is defined in the factory partition as WLAN MAC address + 1. - Fix board name, as the company name is HooToo and not HOOTOO. - Remove unnecessary packages from the profile. (The end-user is supposed to use mechanisms such as the ImageBuilder in order to add his own set of packages to his own images... while the precompiled images should just contain the core set of packages needed to run the base functions of a wireless router.) Signed-off-by: Vittorio Gambaletta <openwrt@vittgam.net> SVN-Revision: 43883
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/hootoo.mk18
1 files changed, 4 insertions, 14 deletions
diff --git a/target/linux/ramips/rt305x/profiles/hootoo.mk b/target/linux/ramips/rt305x/profiles/hootoo.mk
index 976226d5bd..efd23ed11e 100644
--- a/target/linux/ramips/rt305x/profiles/hootoo.mk
+++ b/target/linux/ramips/rt305x/profiles/hootoo.mk
@@ -1,27 +1,17 @@
#
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-
define Profile/HT-TM02
- NAME:=HOOTOO HT-TM02
- PACKAGES:=\
- wpad-mini \
- kmod-ledtrig-netdev kmod-ledtrig-timer kmod-leds-gpio kmod-ledtrig-default-on \
- kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-net usbutils \
- kmod-scsi-core kmod-scsi-generic kmod-fs-ext4 \
- kmod-usb-storage kmod-usb-storage-extras block-mount \
- kmod-usb-serial kmod-usb-serial-ftdi kmod-gpio-button-hotplug \
- kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-utf8 luci luci-mod-admin-full \
- kmod-app-samba luci-theme-openwrt luci-proto-relay relayd nano \
- fstools
+ NAME:=HooToo HT-TM02
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
endef
define Profile/HT-TM02/Description
- Package set for HOOTOO HT-TM02 board
+ Package set optimized for the HooToo HT-TM02.
endef
$(eval $(call Profile,HT-TM02))