summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-07-22 15:36:39 +0000
committerJohn Crispin <john@openwrt.org>2013-07-22 15:36:39 +0000
commit0cc1e2acb41a6c0e24579fe35313c81a0751a71a (patch)
treed4c080590dc3d944aa87d3dedbd350db98815317 /target/linux/ramips/rt305x
parent11d027380ea8105a7e9120fbc5fb74f32435b82b (diff)
downloadmaster-31e0f0ae-0cc1e2acb41a6c0e24579fe35313c81a0751a71a.tar.gz
master-31e0f0ae-0cc1e2acb41a6c0e24579fe35313c81a0751a71a.tar.bz2
master-31e0f0ae-0cc1e2acb41a6c0e24579fe35313c81a0751a71a.zip
ramips: Add support for Huawei HG255D in trunk
HG255D is a kind of popular low-end home gateway in China, this patch bring the the trunk support for it. It is adapted from a local Chinese community (www.right.com.cn), so credit should given to them. This patch is tested to work except trivial LED issues. Signed-off-by: Leon Xu <ylxu72@gmail.com> SVN-Revision: 37505
Diffstat (limited to 'target/linux/ramips/rt305x')
-rw-r--r--target/linux/ramips/rt305x/profiles/hg255d.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/hg255d.mk b/target/linux/ramips/rt305x/profiles/hg255d.mk
new file mode 100644
index 0000000000..9aebe093ce
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/hg255d.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/HG255D
+ NAME:=HuaWei HG255D
+ PACKAGES:=kmod-leds-gpio kmod-rt2800-pci wpad-mini kmod-usb-dwc2
+endef
+
+define Profile/HG255D/Description
+ Package set for HuaWei HG255D.
+endef
+
+$(eval $(call Profile,HG255D))