summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-04-22 08:08:51 +0000
committerJohn Crispin <john@openwrt.org>2014-04-22 08:08:51 +0000
commitcd5f3584e2c2044c2cd53d723350a8d02b227aff (patch)
tree3095f0a68cfbd8e96d0a23d86608057aba1302fd /target/linux/ramips/rt305x/profiles
parent4f3c74011048239eb5c37a2740c428b59d161387 (diff)
downloadmaster-31e0f0ae-cd5f3584e2c2044c2cd53d723350a8d02b227aff.tar.gz
master-31e0f0ae-cd5f3584e2c2044c2cd53d723350a8d02b227aff.tar.bz2
master-31e0f0ae-cd5f3584e2c2044c2cd53d723350a8d02b227aff.zip
ramips: Add support for the 7Links PX-4885 wireless router.
The 7Links PX-4885 is a small battery-powered wireless router. It is based on a RT5350F WiSoC and features one ethernet port and one USB port. It is a Hame MPR-A1 clone, except it has different GPIOs, a different battery and more RAM (32 MB). This patch adds a profile for this board, the corresponding device tree file and the adequate base-files changes (incl. sysupgrade). Signed-off-by: Hugo Grostabussiat <bonstra@bonstra.fr.eu.org> SVN-Revision: 40554
Diffstat (limited to 'target/linux/ramips/rt305x/profiles')
-rw-r--r--target/linux/ramips/rt305x/profiles/sevenlinks.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/sevenlinks.mk b/target/linux/ramips/rt305x/profiles/sevenlinks.mk
new file mode 100644
index 0000000000..424d16a796
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/sevenlinks.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/PX4885
+ NAME:=7Links PX-4885
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-rt305x-dwc_otg kmod-usb2 kmod-usb-ohci \
+ kmod-ledtrig-usbdev kmod-leds-gpio
+endef
+
+define Profile/PX4885/Description
+ Package set for 7Links PX-4885 wireless router.
+endef
+
+$(eval $(call Profile,PX4885))
+