summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-08-01 20:51:24 +0000
committerJohn Crispin <john@openwrt.org>2014-08-01 20:51:24 +0000
commit21845cb45da7b6da12fe977b38bfa68d4f72d9c1 (patch)
tree4dd22a22de081e295e8b9c5553d70eda0b55ea25 /target/linux/ramips/rt305x/profiles
parent7d9bac5247ce79c0ac849ee35a74b54fb713a408 (diff)
downloadmaster-31e0f0ae-21845cb45da7b6da12fe977b38bfa68d4f72d9c1.tar.gz
master-31e0f0ae-21845cb45da7b6da12fe977b38bfa68d4f72d9c1.tar.bz2
master-31e0f0ae-21845cb45da7b6da12fe977b38bfa68d4f72d9c1.zip
ramips: Add support for VoCore
This is based and tested on VoCore Alpha, but other stuff like status/eth LEDs are present on the final board revision + VoDock. All GPIOs are exported, except spi/i2c. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 41939
Diffstat (limited to 'target/linux/ramips/rt305x/profiles')
-rw-r--r--target/linux/ramips/rt305x/profiles/vocore.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/vocore.mk b/target/linux/ramips/rt305x/profiles/vocore.mk
new file mode 100644
index 0000000000..11fb634beb
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/vocore.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/VOCORE
+ NAME:=VoCore
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-i2c-core kmod-i2c-ralink
+endef
+
+define Profile/VOCORE/Description
+ Package set for VoCore board
+endef
+
+$(eval $(call Profile,VOCORE))