summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/asus.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-06-19 14:13:07 +0000
committerJohn Crispin <john@openwrt.org>2014-06-19 14:13:07 +0000
commit9284956ad87d5ed67fbf7246ea68a4f9544312f3 (patch)
treecefab85712bcecc3b075e31cb1f41ea15c85f05d /target/linux/ramips/rt305x/profiles/asus.mk
parent432f7e52dbc55d02ea8336fe5c0d76b04c04b58e (diff)
downloadmaster-31e0f0ae-9284956ad87d5ed67fbf7246ea68a4f9544312f3.tar.gz
master-31e0f0ae-9284956ad87d5ed67fbf7246ea68a4f9544312f3.tar.bz2
master-31e0f0ae-9284956ad87d5ed67fbf7246ea68a4f9544312f3.zip
ramips: cleanup some rt305x profiles
move both asus boards to asus.mk rename HW5503G profile to HW550-3G to match name in image/Makefile (fixes #16599) Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 41271
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/asus.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/asus.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/asus.mk b/target/linux/ramips/rt305x/profiles/asus.mk
new file mode 100644
index 0000000000..fcf4aa4759
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/asus.mk
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RT-N10-PLUS
+ NAME:=Asus RT-N10+
+ PACKAGES:=kmod-leds-gpio wpa
+endef
+
+define Profile/RT-N10-PLUS/Description
+ Package set for Asus RT-N10+.
+endef
+
+define Profile/RT-N13U
+ NAME:=Asus RT-N13U
+ PACKAGES:=kmod-leds-gpio kmod-rt2800-pci wpad-mini kmod-usb-rt305x-dwc_otg
+endef
+
+define Profile/RT-N13U/Description
+ Package set for Asus RT-N13U.
+endef
+
+$(eval $(call Profile,RT-N10-PLUS))
+$(eval $(call Profile,RT-N13U))