summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt288x
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-01-06 11:11:42 +0000
committerJohn Crispin <john@openwrt.org>2013-01-06 11:11:42 +0000
commitf2f933235039d37fb360b77b9e73c5975c65e328 (patch)
tree341489af7b1b8261dd8a8d896d5b305e8db27961 /target/linux/ramips/rt288x
parent2739a19992fe9dabafe4855732736f8e7eb23bd9 (diff)
downloadmaster-31e0f0ae-f2f933235039d37fb360b77b9e73c5975c65e328.tar.gz
master-31e0f0ae-f2f933235039d37fb360b77b9e73c5975c65e328.tar.bz2
master-31e0f0ae-f2f933235039d37fb360b77b9e73c5975c65e328.zip
adds support for Edimax BR-6524N
fixes #12754 Signed-off-by: <rq@akl.lt> SVN-Revision: 35020
Diffstat (limited to 'target/linux/ramips/rt288x')
-rw-r--r--target/linux/ramips/rt288x/config-3.61
-rw-r--r--target/linux/ramips/rt288x/profiles/edimax.mk18
2 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ramips/rt288x/config-3.6 b/target/linux/ramips/rt288x/config-3.6
index eefe11eb12..e2a7c3c3a3 100644
--- a/target/linux/ramips/rt288x/config-3.6
+++ b/target/linux/ramips/rt288x/config-3.6
@@ -97,6 +97,7 @@ CONFIG_RALINK_RT288X=y
CONFIG_RAMIPS_WDT=y
CONFIG_RT288X_MACH_F5D8235_V1=y
CONFIG_RT288X_MACH_RT_N15=y
+CONFIG_RT288X_MACH_BR6524N=y
CONFIG_RT288X_MACH_V11ST_FE=y
CONFIG_RT288X_MACH_WLI_TX4_AG300N=y
CONFIG_RT288X_MACH_WZR_AGL300NH=y
diff --git a/target/linux/ramips/rt288x/profiles/edimax.mk b/target/linux/ramips/rt288x/profiles/edimax.mk
new file mode 100644
index 0000000000..43ac818370
--- /dev/null
+++ b/target/linux/ramips/rt288x/profiles/edimax.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BR6524N
+ NAME:=Edimax BR6524N
+ PACKAGES:=kmod-switch-ip17xx kmod-swconfig swconfig
+endef
+
+define Profile/BR6524N/Description
+ Package set for Edimax BR6524N
+endef
+
+$(eval $(call Profile,BR6524N))
+