summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-4.4
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-05-23 12:16:29 +0200
committerJohn Crispin <john@phrozen.org>2016-05-23 20:22:22 +0200
commitbf6634339afa3dfcd2c00c183a04f7f1f09bc337 (patch)
tree9ca483fbdbc9cdeb292eb7d3b586a3949e483700 /target/linux/ramips/patches-4.4
parente0b241bb489b82b42338a7469f5b5bd387f4c100 (diff)
downloadmaster-31e0f0ae-bf6634339afa3dfcd2c00c183a04f7f1f09bc337.tar.gz
master-31e0f0ae-bf6634339afa3dfcd2c00c183a04f7f1f09bc337.tar.bz2
master-31e0f0ae-bf6634339afa3dfcd2c00c183a04f7f1f09bc337.zip
ramips: fix timing issues when using MT7621 spi
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ramips/patches-4.4')
-rw-r--r--target/linux/ramips/patches-4.4/0043-spi-add-mt7621-support.patch9
1 files changed, 6 insertions, 3 deletions
diff --git a/target/linux/ramips/patches-4.4/0043-spi-add-mt7621-support.patch b/target/linux/ramips/patches-4.4/0043-spi-add-mt7621-support.patch
index 7b264b61f8..e0b63901ee 100644
--- a/target/linux/ramips/patches-4.4/0043-spi-add-mt7621-support.patch
+++ b/target/linux/ramips/patches-4.4/0043-spi-add-mt7621-support.patch
@@ -13,7 +13,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
-@@ -483,6 +483,12 @@ config SPI_RT2880
+@@ -483,6 +483,12 @@
help
This selects a driver for the Ralink RT288x/RT305x SPI Controller.
@@ -28,7 +28,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
depends on ARCH_S3C24XX
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
-@@ -51,6 +51,7 @@ obj-$(CONFIG_SPI_MPC512x_PSC) += spi-mp
+@@ -51,6 +51,7 @@
obj-$(CONFIG_SPI_MPC52xx_PSC) += spi-mpc52xx-psc.o
obj-$(CONFIG_SPI_MPC52xx) += spi-mpc52xx.o
obj-$(CONFIG_SPI_MT65XX) += spi-mt65xx.o
@@ -38,7 +38,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
obj-$(CONFIG_SPI_OC_TINY) += spi-oc-tiny.o
--- /dev/null
+++ b/drivers/spi/spi-mt7621.c
-@@ -0,0 +1,480 @@
+@@ -0,0 +1,483 @@
+/*
+ * spi-mt7621.c -- MediaTek MT7621 SPI controller driver
+ *
@@ -240,6 +240,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+ if (!buf)
+ continue;
+
++ if (t->speed_hz < speed)
++ speed = t->speed_hz;
++
+ if (WARN_ON(len + t->len > 36)) {
+ status = -EIO;
+ goto msg_done;