summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-4.3/0028-GPIO-ralink-add-mt7621-gpio-controller.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-12-11 15:03:16 +0000
committerJohn Crispin <john@openwrt.org>2015-12-11 15:03:16 +0000
commitfbc1624d6aa38b0b60e4ec9779da3f334faf4b8e (patch)
treec368e6296121b639d9b941ae8cd1b2dddb15d1cd /target/linux/ramips/patches-4.3/0028-GPIO-ralink-add-mt7621-gpio-controller.patch
parent4076d12f41e7fd338e9140c1f431002f4ffaf953 (diff)
downloadmaster-31e0f0ae-fbc1624d6aa38b0b60e4ec9779da3f334faf4b8e.tar.gz
master-31e0f0ae-fbc1624d6aa38b0b60e4ec9779da3f334faf4b8e.tar.bz2
master-31e0f0ae-fbc1624d6aa38b0b60e4ec9779da3f334faf4b8e.zip
ramips: irq handlers do not get irq in 4.3 kernel, update patches
This resolves compilation warnings like this: drivers/gpio/gpio-mt7621.c: In function 'mediatek_gpio_probe': drivers/gpio/gpio-mt7621.c:328:46: warning: passing argument 2 of 'irq_set_chained_handler' from incompatible pointer type [-Wincompatible-pointer-types] irq_set_chained_handler(mediatek_gpio_irq, mediatek_gpio_irq_handler); Signed-off-by: Nikolay Martynov <mar.kolya@gmail.com> SVN-Revision: 47841
Diffstat (limited to 'target/linux/ramips/patches-4.3/0028-GPIO-ralink-add-mt7621-gpio-controller.patch')
-rw-r--r--target/linux/ramips/patches-4.3/0028-GPIO-ralink-add-mt7621-gpio-controller.patch16
1 files changed, 2 insertions, 14 deletions
diff --git a/target/linux/ramips/patches-4.3/0028-GPIO-ralink-add-mt7621-gpio-controller.patch b/target/linux/ramips/patches-4.3/0028-GPIO-ralink-add-mt7621-gpio-controller.patch
index 9e16aa3c4d..e18032d1ca 100644
--- a/target/linux/ramips/patches-4.3/0028-GPIO-ralink-add-mt7621-gpio-controller.patch
+++ b/target/linux/ramips/patches-4.3/0028-GPIO-ralink-add-mt7621-gpio-controller.patch
@@ -12,8 +12,6 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
4 files changed, 364 insertions(+)
create mode 100644 drivers/gpio/gpio-mt7621.c
-diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
-index 0098bff..94ea345 100644
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -559,6 +559,9 @@ config RALINK
@@ -26,8 +24,6 @@ index 0098bff..94ea345 100644
config SGI_IP22
bool "SGI IP22 (Indy/Indigo2)"
-diff --git a/drivers/gpio/Kconfig b/drivers/gpio/Kconfig
-index 4a3e7df..13f860c 100644
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -269,6 +269,12 @@ config GPIO_MB86S7X
@@ -43,18 +39,13 @@ index 4a3e7df..13f860c 100644
config GPIO_MM_LANTIQ
bool "Lantiq Memory mapped GPIOs"
depends on LANTIQ && SOC_XWAY
-diff --git a/drivers/gpio/Makefile b/drivers/gpio/Makefile
-index 13448d78..5563d6e 100644
--- a/drivers/gpio/Makefile
+++ b/drivers/gpio/Makefile
-@@ -119,3 +119,4 @@ obj-$(CONFIG_GPIO_XTENSA) += gpio-xtensa.o
+@@ -119,3 +119,4 @@ obj-$(CONFIG_GPIO_XTENSA) += gpio-xtensa
obj-$(CONFIG_GPIO_ZEVIO) += gpio-zevio.o
obj-$(CONFIG_GPIO_ZYNQ) += gpio-zynq.o
obj-$(CONFIG_GPIO_ZX) += gpio-zx.o
+obj-$(CONFIG_GPIO_MT7621) += gpio-mt7621.o
-diff --git a/drivers/gpio/gpio-mt7621.c b/drivers/gpio/gpio-mt7621.c
-new file mode 100644
-index 0000000..7a98b94
--- /dev/null
+++ b/drivers/gpio/gpio-mt7621.c
@@ -0,0 +1,354 @@
@@ -243,7 +234,7 @@ index 0000000..7a98b94
+}
+
+static void
-+mediatek_gpio_irq_handler(unsigned int irq, struct irq_desc *desc)
++mediatek_gpio_irq_handler(struct irq_desc *desc)
+{
+ int i;
+
@@ -412,6 +403,3 @@ index 0000000..7a98b94
+}
+
+subsys_initcall(mediatek_gpio_init);
---
-1.7.10.4
-