summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-07-14 18:01:00 +0000
committerJohn Crispin <john@openwrt.org>2013-07-14 18:01:00 +0000
commitf7cf157712d95459e6d5c27d061cdc6aa2090c1e (patch)
tree9951d16ae938100d77e75b00d7ac9386703d5e2a /target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch
parent6d7e4776918652bce5e2b5da1a8f3ce401348af4 (diff)
downloadmaster-31e0f0ae-f7cf157712d95459e6d5c27d061cdc6aa2090c1e.tar.gz
master-31e0f0ae-f7cf157712d95459e6d5c27d061cdc6aa2090c1e.tar.bz2
master-31e0f0ae-f7cf157712d95459e6d5c27d061cdc6aa2090c1e.zip
ramips: disable ill_acc driver by default
The driver seems to be causoing boot rpoblems on some SoCs Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37314
Diffstat (limited to 'target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch')
-rw-r--r--target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch22
1 files changed, 13 insertions, 9 deletions
diff --git a/target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch b/target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch
index c82b7a97c2..e29a52db2c 100644
--- a/target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch
+++ b/target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch
@@ -10,19 +10,23 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
2 files changed, 88 insertions(+), 1 deletion(-)
create mode 100644 arch/mips/ralink/ill_acc.c
---- a/arch/mips/ralink/Makefile
-+++ b/arch/mips/ralink/Makefile
-@@ -6,7 +6,7 @@
- # Copyright (C) 2009-2011 Gabor Juhos <juhosg@openwrt.org>
- # Copyright (C) 2013 John Crispin <blogic@openwrt.org>
+Index: linux-3.9.10/arch/mips/ralink/Makefile
+===================================================================
+--- linux-3.9.10.orig/arch/mips/ralink/Makefile 2013-07-14 10:54:04.242545881 +0200
++++ linux-3.9.10/arch/mips/ralink/Makefile 2013-07-14 11:42:58.726615805 +0200
+@@ -8,6 +8,8 @@
--obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o timer.o
-+obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o timer.o ill_acc.o
+ obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o timer.o
++obj-$(CONFIG_RALINK_ILL_ACC) += ill_acc.o
++
obj-$(CONFIG_SOC_RT288X) += rt288x.o
obj-$(CONFIG_SOC_RT305X) += rt305x.o
---- /dev/null
-+++ b/arch/mips/ralink/ill_acc.c
+ obj-$(CONFIG_SOC_RT3883) += rt3883.o
+Index: linux-3.9.10/arch/mips/ralink/ill_acc.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-3.9.10/arch/mips/ralink/ill_acc.c 2013-07-14 10:54:04.318545882 +0200
@@ -0,0 +1,87 @@
+/*
+ * This program is free software; you can redistribute it and/or modify it