summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.8/0205-owrt-MIPS-add-OWRTDTB-secion.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-07-14 18:00:34 +0000
committerJohn Crispin <john@openwrt.org>2013-07-14 18:00:34 +0000
commit89c03927368852cf912e76d553bcc7671f6c16cd (patch)
treec396a709343fe323501f82c078fc93d435701e9b /target/linux/ramips/patches-3.8/0205-owrt-MIPS-add-OWRTDTB-secion.patch
parenteb0a44917eea1b2d673d26c28df5aecbb8d77d67 (diff)
downloadmaster-31e0f0ae-89c03927368852cf912e76d553bcc7671f6c16cd.tar.gz
master-31e0f0ae-89c03927368852cf912e76d553bcc7671f6c16cd.tar.bz2
master-31e0f0ae-89c03927368852cf912e76d553bcc7671f6c16cd.zip
ralink: drop v3.8 support
Signed-off-by: John Crispin <blogic@opewnrt.org> SVN-Revision: 37311
Diffstat (limited to 'target/linux/ramips/patches-3.8/0205-owrt-MIPS-add-OWRTDTB-secion.patch')
-rw-r--r--target/linux/ramips/patches-3.8/0205-owrt-MIPS-add-OWRTDTB-secion.patch52
1 files changed, 0 insertions, 52 deletions
diff --git a/target/linux/ramips/patches-3.8/0205-owrt-MIPS-add-OWRTDTB-secion.patch b/target/linux/ramips/patches-3.8/0205-owrt-MIPS-add-OWRTDTB-secion.patch
deleted file mode 100644
index b1e8058c7b..0000000000
--- a/target/linux/ramips/patches-3.8/0205-owrt-MIPS-add-OWRTDTB-secion.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 6beb1af1b1475478c8f275b9579c9ebe4dad2904 Mon Sep 17 00:00:00 2001
-From: John Crispin <blogic@openwrt.org>
-Date: Tue, 19 Mar 2013 10:16:42 +0100
-Subject: [PATCH 205/208] owrt: MIPS: add OWRTDTB secion
-
-Signed-off-by: John Crispin <blogic@openwrt.org>
----
- arch/mips/kernel/head.S | 3 +++
- arch/mips/ralink/Makefile | 2 +-
- arch/mips/ralink/of.c | 4 +++-
- 3 files changed, 7 insertions(+), 2 deletions(-)
-
---- a/arch/mips/kernel/head.S
-+++ b/arch/mips/kernel/head.S
-@@ -146,6 +146,9 @@ EXPORT(__image_cmdline)
- .fill 0x400
- #endif /* CONFIG_IMAGE_CMDLINE_HACK */
-
-+ .ascii "OWRTDTB:"
-+ EXPORT(__image_dtb)
-+ .fill 0x4000
- __REF
-
- NESTED(kernel_entry, 16, sp) # kernel entry point
---- a/arch/mips/ralink/Makefile
-+++ b/arch/mips/ralink/Makefile
-@@ -15,4 +15,4 @@ obj-$(CONFIG_SOC_MT7620) += mt7620.o
-
- obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
-
--obj-y += dts/
-+#obj-y += dts/
---- a/arch/mips/ralink/of.c
-+++ b/arch/mips/ralink/of.c
-@@ -77,6 +77,8 @@ void __init device_tree_init(void)
- free_bootmem(base, size);
- }
-
-+extern struct boot_param_header __image_dtb;
-+
- void __init plat_mem_setup(void)
- {
- set_io_port_base(KSEG1);
-@@ -85,7 +87,7 @@ void __init plat_mem_setup(void)
- * Load the builtin devicetree. This causes the chosen node to be
- * parsed resulting in our memory appearing
- */
-- __dt_setup_arch(&__dtb_start);
-+ __dt_setup_arch(&__image_dtb);
-
- if (soc_info.mem_size)
- add_memory_region(soc_info.mem_base, soc_info.mem_size,