summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.10/0203-owrt-MIPS-add-OWRTDTB-secion.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-08-14 18:15:15 +0000
committerJohn Crispin <john@openwrt.org>2013-08-14 18:15:15 +0000
commit9e5b0cc19cebf6ed876c7eace13b887b46e518c0 (patch)
treef246f12adca3e91f5e3708e97c7a4add05cc0ce3 /target/linux/ramips/patches-3.10/0203-owrt-MIPS-add-OWRTDTB-secion.patch
parent2864fb107f00531df0b114d52334d3e00fa5d6c2 (diff)
downloadmaster-31e0f0ae-9e5b0cc19cebf6ed876c7eace13b887b46e518c0.tar.gz
master-31e0f0ae-9e5b0cc19cebf6ed876c7eace13b887b46e518c0.tar.bz2
master-31e0f0ae-9e5b0cc19cebf6ed876c7eace13b887b46e518c0.zip
ramips: update v3.10 patches
Sync the patches with those sent upstream for v3.12. Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37778
Diffstat (limited to 'target/linux/ramips/patches-3.10/0203-owrt-MIPS-add-OWRTDTB-secion.patch')
-rw-r--r--target/linux/ramips/patches-3.10/0203-owrt-MIPS-add-OWRTDTB-secion.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.10/0203-owrt-MIPS-add-OWRTDTB-secion.patch b/target/linux/ramips/patches-3.10/0203-owrt-MIPS-add-OWRTDTB-secion.patch
new file mode 100644
index 0000000000..71d8fe9982
--- /dev/null
+++ b/target/linux/ramips/patches-3.10/0203-owrt-MIPS-add-OWRTDTB-secion.patch
@@ -0,0 +1,52 @@
+From c174d2250e402399ad7dbdd57d51883d8804bba0 Mon Sep 17 00:00:00 2001
+From: John Crispin <blogic@openwrt.org>
+Date: Mon, 15 Jul 2013 00:40:37 +0200
+Subject: [PATCH 31/33] owrt: MIPS: add OWRTDTB secion
+
+Signed-off-by: John Crispin <blogic@openwrt.org>
+---
+ arch/mips/kernel/head.S | 3 +++
+ arch/mips/ralink/Makefile | 2 +-
+ arch/mips/ralink/of.c | 4 +++-
+ 3 files changed, 7 insertions(+), 2 deletions(-)
+
+--- a/arch/mips/kernel/head.S
++++ b/arch/mips/kernel/head.S
+@@ -146,6 +146,9 @@ EXPORT(__image_cmdline)
+ .fill 0x400
+ #endif /* CONFIG_IMAGE_CMDLINE_HACK */
+
++ .ascii "OWRTDTB:"
++ EXPORT(__image_dtb)
++ .fill 0x4000
+ __REF
+
+ NESTED(kernel_entry, 16, sp) # kernel entry point
+--- a/arch/mips/ralink/Makefile
++++ b/arch/mips/ralink/Makefile
+@@ -21,4 +21,4 @@ obj-$(CONFIG_EARLY_PRINTK) += early_prin
+
+ obj-$(CONFIG_DEBUG_FS) += bootrom.o
+
+-obj-y += dts/
++#obj-y += dts/
+--- a/arch/mips/ralink/of.c
++++ b/arch/mips/ralink/of.c
+@@ -77,6 +77,8 @@ void __init device_tree_init(void)
+ //free_bootmem(base, size);
+ }
+
++extern struct boot_param_header __image_dtb;
++
+ void __init plat_mem_setup(void)
+ {
+ set_io_port_base(KSEG1);
+@@ -85,7 +87,7 @@ void __init plat_mem_setup(void)
+ * Load the builtin devicetree. This causes the chosen node to be
+ * parsed resulting in our memory appearing
+ */
+- __dt_setup_arch(&__dtb_start);
++ __dt_setup_arch(&__image_dtb);
+
+ if (soc_info.mem_size)
+ add_memory_region(soc_info.mem_base, soc_info.mem_size * SZ_1M,