summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.10/0026-i2c-MIPS-adds-ralink-I2C-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-07-22 15:31:13 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-07-22 15:31:13 +0000
commitef944dcb85dea57bdc4b42b8b6fcecacf00b2e92 (patch)
tree111f67b615233af594bc5e29460af254bf85274e /target/linux/ramips/patches-3.10/0026-i2c-MIPS-adds-ralink-I2C-driver.patch
parent6a5b4ec7dc2abeecd47345e2fb5aeb83ea50f322 (diff)
downloadmaster-31e0f0ae-ef944dcb85dea57bdc4b42b8b6fcecacf00b2e92.tar.gz
master-31e0f0ae-ef944dcb85dea57bdc4b42b8b6fcecacf00b2e92.tar.bz2
master-31e0f0ae-ef944dcb85dea57bdc4b42b8b6fcecacf00b2e92.zip
kernel: update 3.10 to 3.10.2
Also refresh 3.10 patches. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 37502
Diffstat (limited to 'target/linux/ramips/patches-3.10/0026-i2c-MIPS-adds-ralink-I2C-driver.patch')
-rw-r--r--target/linux/ramips/patches-3.10/0026-i2c-MIPS-adds-ralink-I2C-driver.patch13
1 files changed, 0 insertions, 13 deletions
diff --git a/target/linux/ramips/patches-3.10/0026-i2c-MIPS-adds-ralink-I2C-driver.patch b/target/linux/ramips/patches-3.10/0026-i2c-MIPS-adds-ralink-I2C-driver.patch
index bee64f83fe..0e72ef02c7 100644
--- a/target/linux/ramips/patches-3.10/0026-i2c-MIPS-adds-ralink-I2C-driver.patch
+++ b/target/linux/ramips/patches-3.10/0026-i2c-MIPS-adds-ralink-I2C-driver.patch
@@ -13,9 +13,6 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
create mode 100644 Documentation/devicetree/bindings/i2c/i2c-ralink.txt
create mode 100644 drivers/i2c/busses/i2c-ralink.c
-diff --git a/Documentation/devicetree/bindings/i2c/i2c-ralink.txt b/Documentation/devicetree/bindings/i2c/i2c-ralink.txt
-new file mode 100644
-index 0000000..8fa8ac3
--- /dev/null
+++ b/Documentation/devicetree/bindings/i2c/i2c-ralink.txt
@@ -0,0 +1,27 @@
@@ -46,8 +43,6 @@ index 0000000..8fa8ac3
+ };
+ };
+};
-diff --git a/drivers/i2c/busses/Kconfig b/drivers/i2c/busses/Kconfig
-index 631736e..e2c2381 100644
--- a/drivers/i2c/busses/Kconfig
+++ b/drivers/i2c/busses/Kconfig
@@ -628,6 +628,10 @@ config I2C_PXA_SLAVE
@@ -61,8 +56,6 @@ index 631736e..e2c2381 100644
config HAVE_S3C2410_I2C
bool
help
-diff --git a/drivers/i2c/busses/Makefile b/drivers/i2c/busses/Makefile
-index 8f4fc23..7e39a13 100644
--- a/drivers/i2c/busses/Makefile
+++ b/drivers/i2c/busses/Makefile
@@ -62,6 +62,7 @@ obj-$(CONFIG_I2C_PNX) += i2c-pnx.o
@@ -73,9 +66,6 @@ index 8f4fc23..7e39a13 100644
obj-$(CONFIG_I2C_S3C2410) += i2c-s3c2410.o
obj-$(CONFIG_I2C_S6000) += i2c-s6000.o
obj-$(CONFIG_I2C_SH7760) += i2c-sh7760.o
-diff --git a/drivers/i2c/busses/i2c-ralink.c b/drivers/i2c/busses/i2c-ralink.c
-new file mode 100644
-index 0000000..f4dc13d
--- /dev/null
+++ b/drivers/i2c/busses/i2c-ralink.c
@@ -0,0 +1,274 @@
@@ -353,6 +343,3 @@ index 0000000..f4dc13d
+MODULE_DESCRIPTION("Ralink I2c host driver");
+MODULE_LICENSE("GPL");
+MODULE_ALIAS("platform:Ralink-I2C");
---
-1.7.10.4
-