summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-2.6.39/105-usb_dwc_otg.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-08-15 14:11:55 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-08-15 14:11:55 +0000
commit169d68c98c6d9c7df824bed5b4d5bc7c39129666 (patch)
tree412a7fa301a9fabcc83f1b0289968321029ad3d2 /target/linux/ramips/patches-2.6.39/105-usb_dwc_otg.patch
parent0ca16a4600ac2d51b068c8fa70361ed2f5f0edd7 (diff)
downloadmaster-31e0f0ae-169d68c98c6d9c7df824bed5b4d5bc7c39129666.tar.gz
master-31e0f0ae-169d68c98c6d9c7df824bed5b4d5bc7c39129666.tar.bz2
master-31e0f0ae-169d68c98c6d9c7df824bed5b4d5bc7c39129666.zip
ramips: rt305x: add dwc_otg driver
Based on a patch by Layne Edwards <ledwards@astrumtech.net> SVN-Revision: 27997
Diffstat (limited to 'target/linux/ramips/patches-2.6.39/105-usb_dwc_otg.patch')
-rw-r--r--target/linux/ramips/patches-2.6.39/105-usb_dwc_otg.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-2.6.39/105-usb_dwc_otg.patch b/target/linux/ramips/patches-2.6.39/105-usb_dwc_otg.patch
new file mode 100644
index 0000000000..583202c528
--- /dev/null
+++ b/target/linux/ramips/patches-2.6.39/105-usb_dwc_otg.patch
@@ -0,0 +1,16 @@
+--- a/drivers/usb/Kconfig
++++ b/drivers/usb/Kconfig
+@@ -163,4 +163,6 @@
+
+ source "drivers/usb/otg/Kconfig"
+
++source "drivers/usb/dwc_otg/Kconfig"
++
+ endif # USB_SUPPORT
+--- a/drivers/usb/Makefile
++++ b/drivers/usb/Makefile
+@@ -45,3 +45,4 @@
+
+ obj-$(CONFIG_USB_ATM) += atm/
+ obj-$(CONFIG_USB_SPEEDTOUCH) += atm/
++obj-$(CONFIG_DWC_OTG) += dwc_otg/