summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-2.6.30
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2009-10-23 16:51:51 +0000
committerJohn Crispin <john@openwrt.org>2009-10-23 16:51:51 +0000
commitd95163658cacaad4935f361fb3257904c8df8e4f (patch)
tree43931bc85e59c7348b3fd6f25aef08a6086565c2 /target/linux/ramips/patches-2.6.30
parent21367682e8ab9be4fda6b134c385e482b2ecf4d8 (diff)
downloadmaster-31e0f0ae-d95163658cacaad4935f361fb3257904c8df8e4f.tar.gz
master-31e0f0ae-d95163658cacaad4935f361fb3257904c8df8e4f.tar.bz2
master-31e0f0ae-d95163658cacaad4935f361fb3257904c8df8e4f.zip
adds ethernet driver, esw needs to be moved to swconfig, driver is missing rt288x support, not a platform device yet
SVN-Revision: 18128
Diffstat (limited to 'target/linux/ramips/patches-2.6.30')
-rw-r--r--target/linux/ramips/patches-2.6.30/104-watchdog.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-2.6.30/104-watchdog.patch b/target/linux/ramips/patches-2.6.30/104-watchdog.patch
new file mode 100644
index 0000000000..793bea1c6c
--- /dev/null
+++ b/target/linux/ramips/patches-2.6.30/104-watchdog.patch
@@ -0,0 +1,30 @@
+Index: linux-2.6.30.5/drivers/watchdog/Kconfig
+===================================================================
+--- linux-2.6.30.5.orig/drivers/watchdog/Kconfig 2009-08-16 23:19:38.000000000 +0200
++++ linux-2.6.30.5/drivers/watchdog/Kconfig 2009-09-04 15:19:34.000000000 +0200
+@@ -764,6 +764,13 @@
+ help
+ Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+
++config RAMIPS_WDT
++ tristate "Ralink Watchdog Timer"
++ depends on MIPS_RALINK
++ help
++ Hardware driver for the built-in watchdog timer on Ralink MIPS SoCs.
++
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+Index: linux-2.6.30.5/drivers/watchdog/Makefile
+===================================================================
+--- linux-2.6.30.5.orig/drivers/watchdog/Makefile 2009-08-16 23:19:38.000000000 +0200
++++ linux-2.6.30.5/drivers/watchdog/Makefile 2009-09-04 15:19:34.000000000 +0200
+@@ -105,6 +105,7 @@
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_RAMIPS_WDT) += ramipswdt.o
+
+ # PARISC Architecture
+