summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7628
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-16 09:26:48 +0000
committerJohn Crispin <john@openwrt.org>2016-03-16 09:26:48 +0000
commit99414dbcf1901a8f362e62febe562dacd4595c8e (patch)
tree1927d20fe846d8453e5501087f3a6643b7d438aa /target/linux/ramips/mt7628
parent553c1b793f6de84e8ed545535f1ee54c4c4c0581 (diff)
downloadmaster-31e0f0ae-99414dbcf1901a8f362e62febe562dacd4595c8e.tar.gz
master-31e0f0ae-99414dbcf1901a8f362e62febe562dacd4595c8e.tar.bz2
master-31e0f0ae-99414dbcf1901a8f362e62febe562dacd4595c8e.zip
ramips: Add support for Xiaomi MiWiFi Nano
Xiaomi MiWiFi Nano is based on Mediatek MT7628 with 64MB ram 16MB flash Signed-off-by: Noble Pepper <openwrtmail@noblepepper.com> v3 includes changes suggested by L. D. Pinney & Karl Palsson- Eliminate en25q64 (4MB) flash chip Alphabetization Remove hyphen in model Rename profile from miwifinano.mk to xiaomi.mk Add gpios that are attached to leds SVN-Revision: 49024
Diffstat (limited to 'target/linux/ramips/mt7628')
-rw-r--r--target/linux/ramips/mt7628/profiles/xiaomi.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7628/profiles/xiaomi.mk b/target/linux/ramips/mt7628/profiles/xiaomi.mk
new file mode 100644
index 0000000000..18e53c44b7
--- /dev/null
+++ b/target/linux/ramips/mt7628/profiles/xiaomi.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MiwifiNano
+ NAME:=Xiaomi MiWiFi Nano
+ PACKAGES:=\
+ kmod-usb-core kmod-usb2 kmod-usb-ohci \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/Default/Description
+ Image for Xiaomi MiWiFi Nano
+endef
+$(eval $(call Profile,MiwifiNano))