summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-12-11 15:04:13 +0000
committerJohn Crispin <john@openwrt.org>2015-12-11 15:04:13 +0000
commit9f14006809f6122d68e22394d147e6fe4a47e676 (patch)
treee15a22746785c0ce49e971f412981c5491efce7e /target/linux/ramips/mt7621
parent6cbb1be464941591c567d707a423d4aaea496f1d (diff)
downloadmaster-31e0f0ae-9f14006809f6122d68e22394d147e6fe4a47e676.tar.gz
master-31e0f0ae-9f14006809f6122d68e22394d147e6fe4a47e676.tar.bz2
master-31e0f0ae-9f14006809f6122d68e22394d147e6fe4a47e676.zip
ramips: add additional support for MQmaker WiTi board
The board is based on mt7621AT cpu, and has 16mb nor flash, 256mb of ram, 2 sata ports, microsd card slot, 1 USB 3.0 port and at least one 2.4 and one 5 ghz antenna. This is the 6th submission that adds support for XHCI in the device tree file, along with switching the location of the 2 radio's and addition of the kmod-i2c-mt7621 in the default packages of the profile. Signed-off-by: Sebastian Careba <nitroshift@yahoo.com> SVN-Revision: 47845
Diffstat (limited to 'target/linux/ramips/mt7621')
-rw-r--r--target/linux/ramips/mt7621/profiles/mqmaker.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/mqmaker.mk b/target/linux/ramips/mt7621/profiles/mqmaker.mk
new file mode 100644
index 0000000000..ae35e7dc66
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/mqmaker.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/witi
+ NAME:=MQmaker WiTi
+ FEATURES+=rtc
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci \
+ kmod-rtc-pcf8563 kmod-i2c-mt7621
+endef
+
+define Profile/witi/Description
+ Package set compatible with MQmaker WiTi board.
+endef
+$(eval $(call Profile,witi))