summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-06-18 18:20:40 +0000
committerJohn Crispin <john@openwrt.org>2015-06-18 18:20:40 +0000
commit640b211b1e9350471f7aef7c64ced5a1ef55476e (patch)
tree42c52db64b4c02f43b6f022e01a6a03601ea2159 /target/linux/ramips/mt7621
parentdf1daa469238d71ed0f9e9b2d5224072eab90d29 (diff)
downloadmaster-31e0f0ae-640b211b1e9350471f7aef7c64ced5a1ef55476e.tar.gz
master-31e0f0ae-640b211b1e9350471f7aef7c64ced5a1ef55476e.tar.bz2
master-31e0f0ae-640b211b1e9350471f7aef7c64ced5a1ef55476e.zip
ramips: add support for PandoraBox PBR-M1
This patch is for PandoraBox PBR-M1 which is based on mt7621, all the features work fine, including rtc, leds, button, usb3.0, etc. Signed-off-by: tymon <banglang.huang@foxmail.com> SVN-Revision: 46041
Diffstat (limited to 'target/linux/ramips/mt7621')
-rw-r--r--target/linux/ramips/mt7621/profiles/pbr-m1.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/pbr-m1.mk b/target/linux/ramips/mt7621/profiles/pbr-m1.mk
new file mode 100644
index 0000000000..5b4dfb58cf
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/pbr-m1.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/PBR-M1
+ NAME:=PBR-M1 Device
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev kmod-mt76 kmod-ata-core kmod-ata-ahci \
+ kmod-usb3-mt7621 kmod-rtc-pcf8563
+endef
+
+
+FEATURES+=rtc
+
+define Profile/PBR-M1/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,PBR-M1))