summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-20 06:34:28 +0000
committerJohn Crispin <john@openwrt.org>2015-01-20 06:34:28 +0000
commit607ecb249cb46472694c0b06cf812b2609a3b8dd (patch)
tree65bca39746d77ed3252a35007fe4470d0a09d468 /target/linux/ramips/mt7621
parenteb6acdf6b4b90ace25bc5194c81442a84dd0a026 (diff)
downloadmaster-31e0f0ae-607ecb249cb46472694c0b06cf812b2609a3b8dd.tar.gz
master-31e0f0ae-607ecb249cb46472694c0b06cf812b2609a3b8dd.tar.bz2
master-31e0f0ae-607ecb249cb46472694c0b06cf812b2609a3b8dd.zip
ralink: add support for firewrt
this is a mt7621 based board Signed-off-by: wengbj <linux.c@foxmail.com> SVN-Revision: 44055
Diffstat (limited to 'target/linux/ramips/mt7621')
-rw-r--r--target/linux/ramips/mt7621/profiles/firefly.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/firefly.mk b/target/linux/ramips/mt7621/profiles/firefly.mk
new file mode 100644
index 0000000000..c8292b0d00
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/firefly.mk
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Firefly
+ NAME:=Firefly Device
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid kmod-usb-storage mount-utils usbutils \
+ kmod-sdhci-mt7620 \
+ kmod-fs-ext3 kmod-fs-vfat kmod-fs-ntfs \
+ kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-utf8 \
+ kmod-ledtrig-usbdev \
+ kmod-ata-core \
+ luci \
+ kmod-mt76
+endef
+
+define Profile/Firefly/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Firefly))