summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-04-21 19:47:08 +0000
committerJohn Crispin <john@openwrt.org>2016-04-21 19:47:08 +0000
commit30fbc1a4d146ae0060d02946709fd6d8cc2a2b56 (patch)
tree56f39f7a4012d5199c2875c84ca24ecfa139c372 /target/linux/ramips/mt7621
parenta6c7c0029e7ac71b340690647c74cd509469b1d8 (diff)
downloadmaster-31e0f0ae-30fbc1a4d146ae0060d02946709fd6d8cc2a2b56.tar.gz
master-31e0f0ae-30fbc1a4d146ae0060d02946709fd6d8cc2a2b56.tar.bz2
master-31e0f0ae-30fbc1a4d146ae0060d02946709fd6d8cc2a2b56.zip
ramips: Add support for ZBT WG3526
The WG3526 is the follow-up to the 2626 and is mostly the same, with the excaption that the mt7602 has been replaced with the mt7603. The internal wifi setup has also changed slightly. Based on my tests, everything that worked on the 2626 works on the 3526 and with roughly the same performance. v1->v2: * Remove some references to 2626 that I had missed in the dts. v2->v3: * Update patch to match new file structure. * Removed SD driver to be consistent with other MT7621 targets. Signed-off-by: Kristian Evensen <kristian.evensen@gmail.com> SVN-Revision: 49213
Diffstat (limited to 'target/linux/ramips/mt7621')
-rw-r--r--target/linux/ramips/mt7621/profiles/zbt.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/zbt.mk b/target/linux/ramips/mt7621/profiles/zbt.mk
index 0073645181..453687d4c5 100644
--- a/target/linux/ramips/mt7621/profiles/zbt.mk
+++ b/target/linux/ramips/mt7621/profiles/zbt.mk
@@ -16,3 +16,16 @@ define Profile/ZBT-WG2626/Description
Package set for ZBT-WG2626 device
endef
$(eval $(call Profile,ZBT-WG2626))
+
+
+define Profile/ZBT-WG3526
+ NAME:=ZBT-WG3526 Device
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 \
+ kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci
+endef
+
+define Profile/ZBT-WG3526/Description
+ Package set for ZBT-WG3526 device
+endef
+$(eval $(call Profile,ZBT-WG3526))