summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621/profiles
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-24 09:09:22 +0000
committerJohn Crispin <john@openwrt.org>2015-07-24 09:09:22 +0000
commitdcae3723fdde4ef48ee1336abfbd2d57a2b8cc85 (patch)
tree414ae41ba7db48434485cc5a4f46282a35a5153d /target/linux/ramips/mt7621/profiles
parent9c0ed4ce5c57907aa1442c63378cc905796562cc (diff)
downloadmaster-31e0f0ae-dcae3723fdde4ef48ee1336abfbd2d57a2b8cc85.tar.gz
master-31e0f0ae-dcae3723fdde4ef48ee1336abfbd2d57a2b8cc85.tar.bz2
master-31e0f0ae-dcae3723fdde4ef48ee1336abfbd2d57a2b8cc85.zip
ramips: add support for STORYLiNK SAP-G3200U3
STORYLiNK SAP-G3200U3 is an AC1200 router based on MT7621AT+MT7602EN+MT7612EN. It has 128MB DDR3, 8MB NOR FLASH, 5-port Gbps switch and 1x USB 3.0. The following patch adds support for this device. Tested and working: * ethernet * both WiFi radios * USB 3.0 * buttons * ethernet switch and USB diag LEDs * UART * GPIOs Tested and not working: * LEDs for WiFi radios (connected with WiFi chips, not supported in mt76?) * failsafe mode (known problem, needs workaround like other MTK based devices) More information in Wiki: http://wiki.openwrt.org/toh/storylink/sap-g3200u3 Signed-off-by: Piotr Dymacz <pepe2k@gmail.com> SVN-Revision: 46454
Diffstat (limited to 'target/linux/ramips/mt7621/profiles')
-rw-r--r--target/linux/ramips/mt7621/profiles/sap-g3200u3.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7621/profiles/sap-g3200u3.mk b/target/linux/ramips/mt7621/profiles/sap-g3200u3.mk
new file mode 100644
index 0000000000..9ca4a2f743
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/sap-g3200u3.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/SAP-G3200U3
+ NAME:=STORYLiNK SAP-G3200U3
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 kmod-usb-hid \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/SAP-G3200U3/Description
+ Package set compatible with the STORYLiNK SAP-G3200U3 board.
+endef
+$(eval $(call Profile,SAP-G3200U3))