summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-04-26 11:43:01 +0000
committerJohn Crispin <john@openwrt.org>2016-04-26 11:43:01 +0000
commite55d86ef323377b40d35cf9d927cd2370e8d4842 (patch)
tree2b7b2f4e2cf2e3eafe827dbc6aa3d0f18845b227 /target/linux/ramips/mt7620
parent83ca0efb3e1e5b765d8b8a6bcb2e681f51b7a944 (diff)
downloadmaster-31e0f0ae-e55d86ef323377b40d35cf9d927cd2370e8d4842.tar.gz
master-31e0f0ae-e55d86ef323377b40d35cf9d927cd2370e8d4842.tar.bz2
master-31e0f0ae-e55d86ef323377b40d35cf9d927cd2370e8d4842.zip
ramips: add support for Planex CS-QR10
CS-QR10 is MT7620A based IP Camera. the camera and sound does not work with kernel 4.4. - camera chip is sn9c291. - sound chip is wm8960. Signed-off-by: YuheiOKAWA <tochiro.srchack@gmail.com> SVN-Revision: 49234
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/planex.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/planex.mk b/target/linux/ramips/mt7620/profiles/planex.mk
index f6f2cf187c..15560ab50d 100644
--- a/target/linux/ramips/mt7620/profiles/planex.mk
+++ b/target/linux/ramips/mt7620/profiles/planex.mk
@@ -5,6 +5,20 @@
# See /LICENSE for more information.
#
+define Profile/CS-QR10
+ NAME:=Planex CS-QR10
+ PACKAGES:=\
+ kmod-usb-core kmod-usb2 kmod-usb-ohci \
+ i2c-core kmod-i2c-ralink kmod-sound-core kmod-sound-mtk \
+ kmod-sdhci-mt7620
+endef
+
+define Profile/CS-QR10/Description
+ Package set optimized for the Planex CS-QR10.
+endef
+$(eval $(call Profile,CS-QR10))
+
+
define Profile/MZK-750DHP
NAME:=Planex MZK-750DHP
PACKAGES:= kmod-mt76 kmod-mt7610e