summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-05 10:26:02 +0000
committerJohn Crispin <john@openwrt.org>2015-10-05 10:26:02 +0000
commitdd8f5abb23c7222e427ad10703164c9aef13b148 (patch)
tree369d53aaf28bfda82875d81fb54f3ab2babdbeb1 /target/linux/ramips/mt7620
parente6e373d3480ebf4f46c9ab2382e8f620c214eca6 (diff)
downloadmaster-31e0f0ae-dd8f5abb23c7222e427ad10703164c9aef13b148.tar.gz
master-31e0f0ae-dd8f5abb23c7222e427ad10703164c9aef13b148.tar.bz2
master-31e0f0ae-dd8f5abb23c7222e427ad10703164c9aef13b148.zip
ramips: Add build files for HiWiFi HC5x61 models
HiWiFi HC5661/5761/5861 models are manufactured by http://www.hiwifi.com <http://www.hiwifi.com/>. These models have similar hardware specs(MT7620A + 128M DDR2 + 16M flash). This patch adds support for them. The original author is Justin Liu (rssnsj@gmail.com). I ported the patch to trunk and submitted it here with his approval. v3 fix 1: Spaces -> Tabs 2: Removed some packages Signed-off-by: Xiaoning Kang <kangxn@163.com> SVN-Revision: 47113
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/hiwifi.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/hiwifi.mk b/target/linux/ramips/mt7620/profiles/hiwifi.mk
new file mode 100644
index 0000000000..5baa85ae88
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/hiwifi.mk
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/HC5661
+ NAME:=HiWiFi HC5661
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-dwc2 kmod-usb2 \
+ kmod-mmc-spi kmod-sdhci kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/HC5661/Description
+ Support HiWiFi HC5661 model(J1S)
+endef
+$(eval $(call Profile,HC5661))
+
+
+define Profile/HC5761
+ NAME:=HiWiFi HC5761
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-dwc2 kmod-usb2 \
+ kmod-mmc-spi kmod-sdhci kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/HC5761/Description
+ Support HiWiFi HC5761 model(J2)
+endef
+$(eval $(call Profile,HC5761))
+
+
+define Profile/HC5861
+ NAME:=HiWiFi HC5861
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-dwc2 kmod-usb2 \
+ kmod-mmc-spi kmod-sdhci kmod-sdhci-mt7620 \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/HC5861/Description
+ Support HiWiFi HC5861 model(J3)
+endef
+$(eval $(call Profile,HC5861))