summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-10 19:12:10 +0000
committerJohn Crispin <john@openwrt.org>2016-03-10 19:12:10 +0000
commitbe7962925927ab5cdc7a13fdb24d1b08792f8f23 (patch)
tree0c17a18e3dbec5c38be2003f1347f9a17ebd8c2f /target/linux/ramips/mt7620
parentbe53e5a154931109dd76a8015583123201c4b602 (diff)
downloadmaster-31e0f0ae-be7962925927ab5cdc7a13fdb24d1b08792f8f23.tar.gz
master-31e0f0ae-be7962925927ab5cdc7a13fdb24d1b08792f8f23.tar.bz2
master-31e0f0ae-be7962925927ab5cdc7a13fdb24d1b08792f8f23.zip
ramips: Add support for GL-MT750
This patch adds support for GL-MT750. GL-MT750 is powered by MT7620A and MT7610e, dual band 802.11ac, 2.4G 300Mbps and 5G 450Mbps. It has 5 LANs, MMC interface, USB, a lot of IOs and PoE support. SVN-Revision: 48994
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/gli.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/gli.mk b/target/linux/ramips/mt7620/profiles/gli.mk
index 6473ff07e5..ae220d5adf 100644
--- a/target/linux/ramips/mt7620/profiles/gli.mk
+++ b/target/linux/ramips/mt7620/profiles/gli.mk
@@ -25,3 +25,12 @@ define Profile/GL-MT300N/Description
endef
$(eval $(call Profile,GL-MT300N))
+define Profile/GL-MT750
+ NAME:=GL-MT750
+ PACKAGES:=kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-mt7610e
+endef
+
+define Profile/GL-MT750/Description
+ Support for gl-mt750 Router
+endef
+$(eval $(call Profile,GL-MT750))