summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-10 19:12:04 +0000
committerJohn Crispin <john@openwrt.org>2016-03-10 19:12:04 +0000
commitbe53e5a154931109dd76a8015583123201c4b602 (patch)
tree095c1a0e5fe884e61ef1cbf3565c24c525997bc2 /target/linux/ramips/mt7620
parent96ee39b184a3863bba1cc42efc5bbd34495d20ff (diff)
downloadmaster-31e0f0ae-be53e5a154931109dd76a8015583123201c4b602.tar.gz
master-31e0f0ae-be53e5a154931109dd76a8015583123201c4b602.tar.bz2
master-31e0f0ae-be53e5a154931109dd76a8015583123201c4b602.zip
ramips: Add support for GL-MT300N
This patch adds support for GL-MT300N. GL-MT300N is powered by MT7620N with 16MB flash, 64MB RAM, 2 LANs, USB, UART, GPIO and PoE support. SVN-Revision: 48993
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/gli.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/gli.mk b/target/linux/ramips/mt7620/profiles/gli.mk
index 53e2e9d578..6473ff07e5 100644
--- a/target/linux/ramips/mt7620/profiles/gli.mk
+++ b/target/linux/ramips/mt7620/profiles/gli.mk
@@ -14,3 +14,14 @@ define Profile/GL-MT300A/Description
Support for gl-mt300a Router
endef
$(eval $(call Profile,GL-MT300A))
+
+define Profile/GL-MT300N
+ NAME:=GL-MT300N
+ PACKAGES:=kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci kmod-mt76
+endef
+
+define Profile/GL-MT300N/Description
+ Support for gl-mt300n Router
+endef
+$(eval $(call Profile,GL-MT300N))
+