summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-09 10:32:37 +0000
committerJohn Crispin <john@openwrt.org>2015-04-09 10:32:37 +0000
commitb7f19a5b261966a6fc2a587ea43c1dd6aa189a55 (patch)
tree5cb8af5935dbe6b65a824b978bc21966139ce97d /target/linux/ramips/mt7620
parentb757a9971a811749930eb6734f9ab2bbb8113c25 (diff)
downloadmaster-31e0f0ae-b7f19a5b261966a6fc2a587ea43c1dd6aa189a55.tar.gz
master-31e0f0ae-b7f19a5b261966a6fc2a587ea43c1dd6aa189a55.tar.bz2
master-31e0f0ae-b7f19a5b261966a6fc2a587ea43c1dd6aa189a55.zip
ramips: Add support for Microduino MicroWRT
MicroWRT is an wireless router with 2 USB,1 ethernet port. It has a 16M flash and 64M DDR2 RAM. You can use most interface, such as i2c, SPI, i2s and PCIe. Besides that there are three expansion borad to combine with the core board. The detailed information, please refer to https://www.microduino.cc/wiki/index.php?title=Main_Page This patch adds support for it. Because there is only one port,so disabled VLAN and use eth0 as lan port. and only a power LED control by power pin. Signed-off-by: 盛凯 <shengkai81@gmail.com> SVN-Revision: 45331
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/microwrt.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/microwrt.mk b/target/linux/ramips/mt7620/profiles/microwrt.mk
new file mode 100644
index 0000000000..2b0977d669
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/microwrt.mk
@@ -0,0 +1,9 @@
+define Profile/MicroWRT
+ NAME:=Microduino MicroWRT
+ PACKAGES:= kmod-usb-core kmod-usb2 kmod-usb-ohci
+endef
+
+define Profile/MicroWRT/Description
+ Package set compatible with MicroWRT
+endef
+$(eval $(call Profile,MicroWRT))