summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-10 19:11:57 +0000
committerJohn Crispin <john@openwrt.org>2016-03-10 19:11:57 +0000
commit96ee39b184a3863bba1cc42efc5bbd34495d20ff (patch)
treee508c929f6adce21d280ac6599c091c4a21a39e0 /target/linux/ramips/mt7620
parent70a5c062f10a63087bd3225454145c3b528a7818 (diff)
downloadmaster-31e0f0ae-96ee39b184a3863bba1cc42efc5bbd34495d20ff.tar.gz
master-31e0f0ae-96ee39b184a3863bba1cc42efc5bbd34495d20ff.tar.bz2
master-31e0f0ae-96ee39b184a3863bba1cc42efc5bbd34495d20ff.zip
ramips: Add support for GL-MT300A
This patches adds support for GL-MT300A. GL-MT300A is powered by MT7620A. It has 16MB flash, 128MB RAM, Two LANs, USB, UART and MMC daughter board. SVN-Revision: 48992
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/gli.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/gli.mk b/target/linux/ramips/mt7620/profiles/gli.mk
new file mode 100644
index 0000000000..53e2e9d578
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/gli.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/GL-MT300A
+ NAME:=GL-MT300A
+ PACKAGES:=kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci kmod-mt76
+endef
+
+define Profile/GL-MT300A/Description
+ Support for gl-mt300a Router
+endef
+$(eval $(call Profile,GL-MT300A))