summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-01 09:17:06 +0000
committerJohn Crispin <john@openwrt.org>2016-03-01 09:17:06 +0000
commit96eb5c6fa8ead2bf749b78dff2f55a340cff020e (patch)
tree656a0d12212f28236f35d09887ac4cccc65032bf /target/linux/ramips/mt7620
parent59121fdd69f04ae766069944d10eacb2a4286316 (diff)
downloadmaster-31e0f0ae-96eb5c6fa8ead2bf749b78dff2f55a340cff020e.tar.gz
master-31e0f0ae-96eb5c6fa8ead2bf749b78dff2f55a340cff020e.tar.bz2
master-31e0f0ae-96eb5c6fa8ead2bf749b78dff2f55a340cff020e.zip
ramips: Added support for ZBT-826 / ZBT-1026
Support for these MT7620-based routers: https://wiki.openwrt.org/toh/zbt/we-826 Based on Oskari’s patches found here: https://dev.openwrt.org/ticket/19996 Signed-off-by: Jamie Stuart <jamie@onebillion.org> SVN-Revision: 48865
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/zbt.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/zbt.mk b/target/linux/ramips/mt7620/profiles/zbt.mk
new file mode 100644
index 0000000000..c33048f4ab
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/zbt.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ZBT-WE826
+ NAME:=ZBT-WE826 Device
+ PACKAGES:=\
+ kmod-scsi-core kmod-scsi-generic kmod-mmc kmod-sdhci \
+ block-mount kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci \
+ kmod-mt76
+endef
+
+define Profile/ZBT-WE826/Description
+ Support for ZBT WE-826-(B,T) routers
+endef
+$(eval $(call Profile,ZBT-WE826))