summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-02-15 18:45:22 +0000
committerJohn Crispin <john@openwrt.org>2016-02-15 18:45:22 +0000
commit8b38a9450bd0e07306641d9250e1565f5804351b (patch)
tree1bf3e527edbc9ab276a30bf6d46a17e5c34610b7 /target/linux/ramips/mt7620
parentf60cc5df9cd10731f883417358f445ad70346ad9 (diff)
downloadmaster-31e0f0ae-8b38a9450bd0e07306641d9250e1565f5804351b.tar.gz
master-31e0f0ae-8b38a9450bd0e07306641d9250e1565f5804351b.tar.bz2
master-31e0f0ae-8b38a9450bd0e07306641d9250e1565f5804351b.zip
ramips: Add support for Phicomm PSG1208
This patch adds support for Phicomm PSG1208.This is a router with MT7620A SoC with 8M flash and 64M ram. The WPS led is uesd as status_led because the power light can't be controlled with GPIO. It seems that the 5g wifi led is connected to MT7612E and it can't be controlled with GPIO too. Signed-off-by: Chuanhong Guo <gch981213@gmail.com> SVN-Revision: 48721
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/phicomm.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/phicomm.mk b/target/linux/ramips/mt7620/profiles/phicomm.mk
new file mode 100644
index 0000000000..e083a4c975
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/phicomm.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/PSG1208
+ NAME:=Phicomm PSG1208
+ PACKAGES:=kmod-mt76
+endef
+
+define Profile/PSG1208/Description
+ Default package set for Phicomm PSG1208.
+endef
+$(eval $(call Profile,PSG1208))