summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-05-11 14:04:40 +0200
committerJohn Crispin <john@phrozen.org>2016-05-12 03:29:36 +0200
commit4220cc325560390db3c2606e9dc4576b2e051bdb (patch)
tree82f87796d031d2a44f8fd138b16643500f6366ac /target/linux/ramips/mt7620
parentecbaaa401a98c7bf94e3e06373fea414c7a27d3e (diff)
downloadmaster-31e0f0ae-4220cc325560390db3c2606e9dc4576b2e051bdb.tar.gz
master-31e0f0ae-4220cc325560390db3c2606e9dc4576b2e051bdb.tar.bz2
master-31e0f0ae-4220cc325560390db3c2606e9dc4576b2e051bdb.zip
ramips: convert mt7620 to new image building code
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ramips/mt7620')
-rw-r--r--target/linux/ramips/mt7620/profiles/00-default.mk4
-rw-r--r--target/linux/ramips/mt7620/profiles/aigale.mk16
-rw-r--r--target/linux/ramips/mt7620/profiles/dovado.mk17
-rw-r--r--target/linux/ramips/mt7620/profiles/elecom.mk18
-rw-r--r--target/linux/ramips/mt7620/profiles/gli.mk36
-rw-r--r--target/linux/ramips/mt7620/profiles/hiwifi.mk47
-rw-r--r--target/linux/ramips/mt7620/profiles/linksys.mk16
-rw-r--r--target/linux/ramips/mt7620/profiles/mediatek.mk15
-rw-r--r--target/linux/ramips/mt7620/profiles/microduino.mk16
-rw-r--r--target/linux/ramips/mt7620/profiles/netgear.mk16
-rw-r--r--target/linux/ramips/mt7620/profiles/phicomm.mk16
-rw-r--r--target/linux/ramips/mt7620/profiles/planex.mk52
-rw-r--r--target/linux/ramips/mt7620/profiles/xiaomi.mk17
-rw-r--r--target/linux/ramips/mt7620/profiles/zbt.mk19
14 files changed, 1 insertions, 304 deletions
diff --git a/target/linux/ramips/mt7620/profiles/00-default.mk b/target/linux/ramips/mt7620/profiles/00-default.mk
index 6c7d721444..55a85a69e9 100644
--- a/target/linux/ramips/mt7620/profiles/00-default.mk
+++ b/target/linux/ramips/mt7620/profiles/00-default.mk
@@ -7,9 +7,7 @@
define Profile/Default
NAME:=Default Profile
- PACKAGES:=\
- kmod-usb-core kmod-usb2 kmod-usb-ohci \
- kmod-ledtrig-usbdev
+ PACKAGES:= kmod-usb-core kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
endef
define Profile/Default/Description
diff --git a/target/linux/ramips/mt7620/profiles/aigale.mk b/target/linux/ramips/mt7620/profiles/aigale.mk
deleted file mode 100644
index 629a378cae..0000000000
--- a/target/linux/ramips/mt7620/profiles/aigale.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/AI-BR100
- NAME:=Aigale Ai-BR100
- PACKAGES:=kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/AI-BR100/Description
- Default package set for Aigale Ai-BR100.
-endef
-$(eval $(call Profile,AI-BR100))
diff --git a/target/linux/ramips/mt7620/profiles/dovado.mk b/target/linux/ramips/mt7620/profiles/dovado.mk
deleted file mode 100644
index 34bc74a2df..0000000000
--- a/target/linux/ramips/mt7620/profiles/dovado.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/TINY-AC
- NAME:=Dovado Tiny AC
- PACKAGES:=\
- kmod-usb-core kmod-usb2 kmod-usb-ohci
-endef
-
-define Profile/TINY-AC/Description
- Support for Dovado Tiny AC router
-endef
-$(eval $(call Profile,TINY-AC))
diff --git a/target/linux/ramips/mt7620/profiles/elecom.mk b/target/linux/ramips/mt7620/profiles/elecom.mk
deleted file mode 100644
index 5c84c92715..0000000000
--- a/target/linux/ramips/mt7620/profiles/elecom.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/WRH-300CR
- NAME:=ELECOM WRH-300CR
- PACKAGES:=\
- kmod-usb-core kmod-usb2 kmod-usb-ohci kmod-usb-storage \
- kmod-scsi-core kmod-fs-ext4 block-mount
-endef
-
-define Profile/WRH-300CR/Description
- Package set optimized for the ELECOM WRH-300CR.
-endef
-$(eval $(call Profile,WRH-300CR))
diff --git a/target/linux/ramips/mt7620/profiles/gli.mk b/target/linux/ramips/mt7620/profiles/gli.mk
deleted file mode 100644
index ae220d5adf..0000000000
--- a/target/linux/ramips/mt7620/profiles/gli.mk
+++ /dev/null
@@ -1,36 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/GL-MT300A
- NAME:=GL-MT300A
- PACKAGES:=kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci kmod-mt76
-endef
-
-define Profile/GL-MT300A/Description
- Support for gl-mt300a Router
-endef
-$(eval $(call Profile,GL-MT300A))
-
-define Profile/GL-MT300N
- NAME:=GL-MT300N
- PACKAGES:=kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci kmod-mt76
-endef
-
-define Profile/GL-MT300N/Description
- Support for gl-mt300n Router
-endef
-$(eval $(call Profile,GL-MT300N))
-
-define Profile/GL-MT750
- NAME:=GL-MT750
- PACKAGES:=kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-mt7610e
-endef
-
-define Profile/GL-MT750/Description
- Support for gl-mt750 Router
-endef
-$(eval $(call Profile,GL-MT750))
diff --git a/target/linux/ramips/mt7620/profiles/hiwifi.mk b/target/linux/ramips/mt7620/profiles/hiwifi.mk
deleted file mode 100644
index 5baa85ae88..0000000000
--- a/target/linux/ramips/mt7620/profiles/hiwifi.mk
+++ /dev/null
@@ -1,47 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/HC5661
- NAME:=HiWiFi HC5661
- PACKAGES:=\
- kmod-usb-core kmod-usb-dwc2 kmod-usb2 \
- kmod-mmc-spi kmod-sdhci kmod-sdhci-mt7620 \
- kmod-ledtrig-usbdev
-endef
-
-define Profile/HC5661/Description
- Support HiWiFi HC5661 model(J1S)
-endef
-$(eval $(call Profile,HC5661))
-
-
-define Profile/HC5761
- NAME:=HiWiFi HC5761
- PACKAGES:=\
- kmod-usb-core kmod-usb-dwc2 kmod-usb2 \
- kmod-mmc-spi kmod-sdhci kmod-sdhci-mt7620 \
- kmod-ledtrig-usbdev
-endef
-
-define Profile/HC5761/Description
- Support HiWiFi HC5761 model(J2)
-endef
-$(eval $(call Profile,HC5761))
-
-
-define Profile/HC5861
- NAME:=HiWiFi HC5861
- PACKAGES:=\
- kmod-usb-core kmod-usb-dwc2 kmod-usb2 \
- kmod-mmc-spi kmod-sdhci kmod-sdhci-mt7620 \
- kmod-ledtrig-usbdev
-endef
-
-define Profile/HC5861/Description
- Support HiWiFi HC5861 model(J3)
-endef
-$(eval $(call Profile,HC5861))
diff --git a/target/linux/ramips/mt7620/profiles/linksys.mk b/target/linux/ramips/mt7620/profiles/linksys.mk
deleted file mode 100644
index d8a2df4593..0000000000
--- a/target/linux/ramips/mt7620/profiles/linksys.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/E1700
- NAME:=Linksys E1700
- PACKAGES:=swconfig
-endef
-
-define Profile/E1700/Description
- Package set compatible with the Linksys E1700.
-endef
-$(eval $(call Profile,E1700))
diff --git a/target/linux/ramips/mt7620/profiles/mediatek.mk b/target/linux/ramips/mt7620/profiles/mediatek.mk
deleted file mode 100644
index 4f6703ebf5..0000000000
--- a/target/linux/ramips/mt7620/profiles/mediatek.mk
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/MT7620a
- NAME:=MT7620a EVB
-endef
-
-define Profile/MT7620a/Description
- Default package set compatible with MT7620a eval board
-endef
-$(eval $(call Profile,MT7620a))
diff --git a/target/linux/ramips/mt7620/profiles/microduino.mk b/target/linux/ramips/mt7620/profiles/microduino.mk
deleted file mode 100644
index b68a269841..0000000000
--- a/target/linux/ramips/mt7620/profiles/microduino.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/MicroWRT
- NAME:=Microduino MicroWRT
- PACKAGES:= kmod-usb-core kmod-usb2 kmod-usb-ohci
-endef
-
-define Profile/MicroWRT/Description
- Package set compatible with MicroWRT
-endef
-$(eval $(call Profile,MicroWRT))
diff --git a/target/linux/ramips/mt7620/profiles/netgear.mk b/target/linux/ramips/mt7620/profiles/netgear.mk
deleted file mode 100644
index d1b073abc2..0000000000
--- a/target/linux/ramips/mt7620/profiles/netgear.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/EX2700
- NAME:=Netgear EX2700
- PACKAGES:=-kmod-usb-core -kmod-usb2 -kmod-usb-ohci -kmod-ledtrig-usbdev
-endef
-
-define Profile/EX2700/Description
- Support for Netgear EX2700
-endef
-$(eval $(call Profile,EX2700))
diff --git a/target/linux/ramips/mt7620/profiles/phicomm.mk b/target/linux/ramips/mt7620/profiles/phicomm.mk
deleted file mode 100644
index e083a4c975..0000000000
--- a/target/linux/ramips/mt7620/profiles/phicomm.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/PSG1208
- NAME:=Phicomm PSG1208
- PACKAGES:=kmod-mt76
-endef
-
-define Profile/PSG1208/Description
- Default package set for Phicomm PSG1208.
-endef
-$(eval $(call Profile,PSG1208))
diff --git a/target/linux/ramips/mt7620/profiles/planex.mk b/target/linux/ramips/mt7620/profiles/planex.mk
deleted file mode 100644
index f461aeb211..0000000000
--- a/target/linux/ramips/mt7620/profiles/planex.mk
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/CS-QR10
- NAME:=Planex CS-QR10
- PACKAGES:=\
- kmod-usb-core kmod-usb2 kmod-usb-ohci \
- i2c-core kmod-i2c-ralink kmod-sound-core kmod-sound-mtk \
- kmod-sdhci-mt7620
-endef
-
-define Profile/CS-QR10/Description
- Package set optimized for the Planex CS-QR10.
-endef
-$(eval $(call Profile,CS-QR10))
-
-
-define Profile/MZK-750DHP
- NAME:=Planex MZK-750DHP
- PACKAGES:= kmod-mt76 kmod-mt7610e
-endef
-
-define Profile/MZK-750DHP/Description
- Package set optimized for the Planex MZK-750DHP.
-endef
-$(eval $(call Profile,MZK-750DHP))
-
-
-define Profile/MZK-EX300NP
- NAME:=Planex MZK-EX300NP
- PACKAGES:=
-endef
-
-define Profile/MZK-EX300NP/Description
- Package set optimized for the Planex MZK-EX300NP.
-endef
-$(eval $(call Profile,MZK-EX300NP))
-
-
-define Profile/MZK-EX750NP
- NAME:=Planex MZK-EX750NP
- PACKAGES:= kmod-mt76 kmod-mt7610e
-endef
-
-define Profile/MZK-EX750NP/Description
- Package set optimized for the Planex MZK-EX750NP.
-endef
-$(eval $(call Profile,MZK-EX750NP))
diff --git a/target/linux/ramips/mt7620/profiles/xiaomi.mk b/target/linux/ramips/mt7620/profiles/xiaomi.mk
deleted file mode 100644
index 84835784e1..0000000000
--- a/target/linux/ramips/mt7620/profiles/xiaomi.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/MIWIFI-MINI
- NAME:=Xiaomi MiWiFi Mini
- PACKAGES:=\
- kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci
-endef
-
-define Profile/MIWIFI-MINI/Description
- Support for Xiaomi MiWiFi Mini routers
-endef
-$(eval $(call Profile,MIWIFI-MINI))
diff --git a/target/linux/ramips/mt7620/profiles/zbt.mk b/target/linux/ramips/mt7620/profiles/zbt.mk
deleted file mode 100644
index c33048f4ab..0000000000
--- a/target/linux/ramips/mt7620/profiles/zbt.mk
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/ZBT-WE826
- NAME:=ZBT-WE826 Device
- PACKAGES:=\
- kmod-scsi-core kmod-scsi-generic kmod-mmc kmod-sdhci \
- block-mount kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci \
- kmod-mt76
-endef
-
-define Profile/ZBT-WE826/Description
- Support for ZBT WE-826-(B,T) routers
-endef
-$(eval $(call Profile,ZBT-WE826))