summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7620/profiles/xiaomi.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-08-17 05:58:15 +0000
committerJohn Crispin <john@openwrt.org>2015-08-17 05:58:15 +0000
commita0b8c601341bfc8684f962e27715dd18a4d667a8 (patch)
tree374adc8a17b69b8177ed1988f4affec4f860696b /target/linux/ramips/mt7620/profiles/xiaomi.mk
parent5a6690a7a64b36f7f3fef4d1a331f5c2a3c5387f (diff)
downloadmaster-31e0f0ae-a0b8c601341bfc8684f962e27715dd18a4d667a8.tar.gz
master-31e0f0ae-a0b8c601341bfc8684f962e27715dd18a4d667a8.tar.bz2
master-31e0f0ae-a0b8c601341bfc8684f962e27715dd18a4d667a8.zip
ramips: fix Xiaomi MiWiFi Mini board, image and profile names
The following patch: * changes board name from "xiaomi-miwifi-mini" to "miwifi-mini" * changes filenames of dts and profile * fixes LED names in dts file and base-files scripts * removes manufacturer name from image filename for Xiaomi MiWiFi Mini device. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com> SVN-Revision: 46617
Diffstat (limited to 'target/linux/ramips/mt7620/profiles/xiaomi.mk')
-rw-r--r--target/linux/ramips/mt7620/profiles/xiaomi.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ramips/mt7620/profiles/xiaomi.mk b/target/linux/ramips/mt7620/profiles/xiaomi.mk
new file mode 100644
index 0000000000..47f6d499dd
--- /dev/null
+++ b/target/linux/ramips/mt7620/profiles/xiaomi.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/MIWIFI-MINI
+ NAME:=Xiaomi MiWiFi Mini
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci \
+ kmod-mt76
+endef
+
+define Profile/MIWIFI-MINI/Description
+ Support for Xiaomi MiWiFi Mini routers
+endef
+$(eval $(call Profile,MIWIFI-MINI))