summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-07-27 09:23:40 +0000
committerJohn Crispin <john@openwrt.org>2013-07-27 09:23:40 +0000
commiteb089abd28a50f6c1b500a7c297703be40ef445e (patch)
tree59e0b432379dbb2564f39ee1259ac579f1352bea /target/linux/ramips/modules.mk
parent718b47f0b482b16cb054ee1e26c7c7c1af20e2a7 (diff)
downloadmaster-31e0f0ae-eb089abd28a50f6c1b500a7c297703be40ef445e.tar.gz
master-31e0f0ae-eb089abd28a50f6c1b500a7c297703be40ef445e.tar.bz2
master-31e0f0ae-eb089abd28a50f6c1b500a7c297703be40ef445e.zip
ramips: add back dwc_otg driver
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37566
Diffstat (limited to 'target/linux/ramips/modules.mk')
-rw-r--r--target/linux/ramips/modules.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 1c84598e45..33b5c23697 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -5,6 +5,27 @@
# See /LICENSE for more information.
#
+define KernelPackage/usb-rt305x-dwc_otg
+ TITLE:=RT305X USB controller driver
+ DEPENDS:=@TARGET_ramips_rt305x
+ KCONFIG:= \
+ CONFIG_DWC_OTG \
+ CONFIG_DWC_OTG_HOST_ONLY=y \
+ CONFIG_DWC_OTG_DEVICE_ONLY=n \
+ CONFIG_DWC_OTG_DEBUG=n
+ FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
+ AUTOLOAD:=$(call AutoLoad,54,dwc_otg,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-rt305x-dwc_otg/description
+ This driver provides USB Device Controller support for the
+ Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
+endef
+
+$(eval $(call KernelPackage,usb-rt305x-dwc_otg))
+
+
I2C_RALINK_MODULES:= \
CONFIG_I2C_RALINK:drivers/i2c/busses/i2c-ralink