summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-14 18:51:41 +0000
committerJohn Crispin <john@openwrt.org>2014-11-14 18:51:41 +0000
commitce1c580efbc0427c7e2e4eca7ddc738fae518aea (patch)
treebbec247f9832f5cf8cf7b43e2ba860fd11708240 /target/linux/ramips/modules.mk
parent76a54a424ca2118da632b43e79feb83b2e7f79b3 (diff)
downloadmaster-31e0f0ae-ce1c580efbc0427c7e2e4eca7ddc738fae518aea.tar.gz
master-31e0f0ae-ce1c580efbc0427c7e2e4eca7ddc738fae518aea.tar.bz2
master-31e0f0ae-ce1c580efbc0427c7e2e4eca7ddc738fae518aea.zip
ralink: make the sdhci module build again
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 43274
Diffstat (limited to 'target/linux/ramips/modules.mk')
-rw-r--r--target/linux/ramips/modules.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 5b57f4c5bc..08eea9bb86 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -9,12 +9,14 @@ OTHER_MENU:=Other modules
define KernelPackage/sdhci-mt7620
SUBMENU:=Other modules
TITLE:=MT7620 SDCI
- DEPENDS:=@TARGET_ramips_mt7620a +kmod-sdhci
+ DEPENDS:=@(TARGET_ramips_mt7620a||TARGET_ramips_mt7628||TARGET_ramips_mt7621) +kmod-sdhci
KCONFIG:= \
- CONFIG_MMC_SDHCI_MT7620
+ CONFIG_MTK_MMC \
+ CONFIG_MTK_AEE_KDUMP=n \
+ CONFIG_MTK_MMC_CD_POLL=n
FILES:= \
- $(LINUX_DIR)/drivers/mmc/host/sdhci-mt7620.ko
- AUTOLOAD:=$(call AutoProbe,sdhci-mt7620,1)
+ $(LINUX_DIR)/drivers/mmc/host/mtk-mmc/mtk_sd.ko
+ AUTOLOAD:=$(call AutoProbe,mtk_sd,1)
endef
$(eval $(call KernelPackage,sdhci-mt7620))