summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/modules.mk
diff options
context:
space:
mode:
authorMichael Lee <igvtee@gmail.com>2016-07-06 11:17:20 +0800
committerJohn Crispin <john@phrozen.org>2016-07-11 14:19:47 +0200
commit9062c4fe99c54dc117d531143bd981b2c64a50ec (patch)
tree5868b5890cff3e9456576cfe80864078c0997ba3 /target/linux/ramips/modules.mk
parentc3e420f28cf1ed229753f94bafdb0d5851748af3 (diff)
downloadmaster-31e0f0ae-9062c4fe99c54dc117d531143bd981b2c64a50ec.tar.gz
master-31e0f0ae-9062c4fe99c54dc117d531143bd981b2c64a50ec.tar.bz2
master-31e0f0ae-9062c4fe99c54dc117d531143bd981b2c64a50ec.zip
ramips: modify audio kernel module and add dma options
* add gdma and hsdma kernel modules * i2s support all ramips targets except rt288x * i2s need gdma to transfer data * add simple audio kernel module. it support device tree binding Signed-off-by: Michael Lee <igvtee@gmail.com>
Diffstat (limited to 'target/linux/ramips/modules.mk')
-rw-r--r--target/linux/ramips/modules.mk44
1 files changed, 42 insertions, 2 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 370d0ccfdc..70678a8376 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -72,18 +72,58 @@ endef
$(eval $(call KernelPackage,i2c-mt7621))
+define KernelPackage/dma-ralink
+ SUBMENU:=Other modules
+ TITLE:=Ralink GDMA Engine
+ DEPENDS:=@TARGET_ramips
+ KCONFIG:= \
+ CONFIG_DMADEVICES=y \
+ CONFIG_DW_DMAC_PCI=n \
+ CONFIG_DMA_RALINK
+ FILES:= \
+ $(LINUX_DIR)/drivers/dma/virt-dma.ko \
+ $(LINUX_DIR)/drivers/dma/ralink-gdma.ko
+ AUTOLOAD:=$(call AutoLoad,52,ralink-gdma)
+endef
+
+define KernelPackage/dma-ralink/description
+ Kernel modules for enable ralink dma engine.
+endef
+
+$(eval $(call KernelPackage,dma-ralink))
+
+define KernelPackage/hsdma-mtk
+ SUBMENU:=Other modules
+ TITLE:=MediaTek HSDMA Engine
+ DEPENDS:=@TARGET_ramips @TARGET_ramips_mt7621
+ KCONFIG:= \
+ CONFIG_DMADEVICES=y \
+ CONFIG_DW_DMAC_PCI=n \
+ CONFIG_MTK_HSDMA
+ FILES:= \
+ $(LINUX_DIR)/drivers/dma/virt-dma.ko \
+ $(LINUX_DIR)/drivers/dma/mtk-hsdma.ko
+ AUTOLOAD:=$(call AutoLoad,53,mtk-hsdma)
+endef
+
+define KernelPackage/hsdma-mtk/description
+ Kernel modules for enable MediaTek hsdma engine.
+endef
+$(eval $(call KernelPackage,hsdma-mtk))
define KernelPackage/sound-mt7620
TITLE:=MT7620 PCM/I2S Alsa Driver
- DEPENDS:=@TARGET_ramips_mt7620 +kmod-sound-soc-core +kmod-regmap @!TARGET_ramips_rt288x
+ DEPENDS:=@TARGET_ramips +kmod-sound-soc-core +kmod-regmap +kmod-dma-ralink @!TARGET_ramips_rt288x
KCONFIG:= \
CONFIG_SND_RALINK_SOC_I2S \
+ CONFIG_SND_SIMPLE_CARD \
CONFIG_SND_SOC_WM8960
FILES:= \
$(LINUX_DIR)/sound/soc/ralink/snd-soc-ralink-i2s.ko \
+ $(LINUX_DIR)/sound/soc/generic/snd-soc-simple-card.ko \
$(LINUX_DIR)/sound/soc/codecs/snd-soc-wm8960.ko
- AUTOLOAD:=$(call AutoLoad,90,snd-soc-wm8960 snd-soc-ralink-i2s)
+ AUTOLOAD:=$(call AutoLoad,90,snd-soc-wm8960 snd-soc-ralink-i2s snd-soc-simple-card)
$(call AddDepends/sound)
endef