summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-10-28 06:47:56 +0000
committerJohn Crispin <john@openwrt.org>2013-10-28 06:47:56 +0000
commit176b41d441487c2e27f412b2fd0aae48f23bff43 (patch)
tree83eafef932989836a6ff629d0959ec25d3a5b9d2 /target/linux/ramips/modules.mk
parent36e029b3eb427804bef3dbcb5f5f9e1372cca2ee (diff)
downloadmaster-31e0f0ae-176b41d441487c2e27f412b2fd0aae48f23bff43.tar.gz
master-31e0f0ae-176b41d441487c2e27f412b2fd0aae48f23bff43.tar.bz2
master-31e0f0ae-176b41d441487c2e27f412b2fd0aae48f23bff43.zip
ralink: add package for mt7620 sdhci
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 38553
Diffstat (limited to 'target/linux/ramips/modules.mk')
-rw-r--r--target/linux/ramips/modules.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 33b5c23697..adf5e0230d 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -25,6 +25,19 @@ endef
$(eval $(call KernelPackage,usb-rt305x-dwc_otg))
+OTHER_MENU:=Other modules
+define KernelPackage/sdhci-mt7620
+ SUBMENU:=Other modules
+ TITLE:=MT7620 SDCI
+ DEPENDS:=@TARGET_ramips_mt7620a +kmod-sdhci
+ KCONFIG:= \
+ CONFIG_MMC_SDHCI_MT7620
+ FILES:= \
+ $(LINUX_DIR)/drivers/mmc/host/sdhci-mt7620.ko
+ AUTOLOAD:=$(call AutoProbe,sdhci-mt7620,1)
+endef
+
+$(eval $(call KernelPackage,sdhci-mt7620))
I2C_RALINK_MODULES:= \
CONFIG_I2C_RALINK:drivers/i2c/busses/i2c-ralink