summaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/modules.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:42 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:42 +0000
commit1627b2bb4b94f2388b54aa1578ed814f58cea264 (patch)
treecf216e2510a2b94f16a690156595c6dee05f2118 /target/linux/ramips/modules.mk
parentc7a69869f7e9773facfdd607a78bb1e4c404af96 (diff)
downloadmaster-31e0f0ae-1627b2bb4b94f2388b54aa1578ed814f58cea264.tar.gz
master-31e0f0ae-1627b2bb4b94f2388b54aa1578ed814f58cea264.tar.bz2
master-31e0f0ae-1627b2bb4b94f2388b54aa1578ed814f58cea264.zip
move rt305x-dwc driver to target specific modules.mk
SVN-Revision: 32864
Diffstat (limited to 'target/linux/ramips/modules.mk')
-rw-r--r--target/linux/ramips/modules.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
new file mode 100644
index 0000000000..0d293323f0
--- /dev/null
+++ b/target/linux/ramips/modules.mk
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/usb-rt305x-dwc_otg
+ TITLE:=RT305X USB controller driver
+ DEPENDS:=@TARGET_ramips_rt305x
+ KCONFIG:= \
+ CONFIG_DWC_OTG \
+ CONFIG_DWC_OTG_HOST_ONLY=y \
+ CONFIG_DWC_OTG_DEVICE_ONLY=n \
+ CONFIG_DWC_OTG_DEBUG=n
+ FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
+ AUTOLOAD:=$(call AutoLoad,54,dwc_otg,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-rt305x-dwc_otg/description
+ This driver provides USB Device Controller support for the
+ Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
+endef
+
+$(eval $(call KernelPackage,usb-rt305x-dwc_otg))